Willkommen im User-Forum von mailbox.org
 

Nach DNS Zonen Umzug: 450 4.1.8: Sender address rejected: Domain not found

3202689 hat dies geteilt, 10 Monaten her
veröffentlicht

Hallo zusammen,


gestern habe ich bei meiner Domain (***) einen neuen NS gesetzt. Und zwar den Hetzner. Daher habe ich zuerst schön alle Eintrage zu Hetzner übertragen (inkl. MX, DKIM etc.) und dann bei Strato neue NS einträge gemacht.

Für alle Einträge lieft das gut, bis auf E-Mail. Wenn ich eine E-Mail verschicke, dann bekomme ich einen fehler:

> openssl s_client -connect smtp.mailbox.org:465
> AUTH LOGIN
> MAIL FROM:***
> rcpt to: ***
450 4.1.8 <***>: Sender address rejected: Domain not found


Ich empfange aktuell auch keine E-Mails mehr.


  • MX Records sind gesetzt:

> dig +short MX ***
10 mxext1.mailbox.org.
10 mxext2.mailbox.org.
20 mxext3.mailbox.org.
  • NS Records sind gesetzt:

> dig +short NS ***
oxygen.ns.hetzner.com.
hydrogen.ns.hetzner.com.
helium.ns.hetzner.de.
  • Domain Authentifizierung läuft auch:

> dig +short TXT authcode.***
"***"


  • DNSSEC ist deaktivert weil Strato das gar nicht kann.


Ich habe den Alias auch schon einmal entfernt und wieder erfolgreich hinzugefügt. Weis jemand warum das nicht geht? Ich meine die Migration hätte doch auch ohne Ausfall funktinieren müssen, wenn ich nur den NS wechel, oder?


Ich bedanke mich schon mal für jeglichen Support!


Schon gelesene Probleme


(E-Mail im nachhinein anonymisiert durch ***)

Beste Antwort
Foto

Oke, wäre ich doch nur 1h später aufgestanden. Jetzt läufts und auch die E-Mail von gestern trudeln ein. Weis jemand warum das so lange gedauert hat? Also bzw warum es die "auszeit" gab obwohl ich nur die NS geändert hab und sonst nichts?

Kommentare (2)

Foto
1

Oke, wäre ich doch nur 1h später aufgestanden. Jetzt läufts und auch die E-Mail von gestern trudeln ein. Weis jemand warum das so lange gedauert hat? Also bzw warum es die "auszeit" gab obwohl ich nur die NS geändert hab und sonst nichts?

Foto
1

Hast du die Einträge bei Strato evtl. gelöscht? DNS verwendet Caching (mit konfigurierbarer Laufzeit). Im blödsten Fall kann es passieren, dass die alten NS-Records noch gecacht sind (und auf die alten Nameserver verweisen), die MX-Records aber nicht mehr (aufgrund kürzerer Einstellungen beim Caching). Und der alte Nameserver nichts mehr gültiges zurückgibt, da bereits gelöscht.

Foto
1

Irgendwie sowas vermute ich auch. Gelöscht habe ich nichts. Aber wer weis das die (leider sehr crappy) software von Strato da so anstellt wenn man den NS ändert. Wahrscheinlich löschen die gleich alles von ihren Nameservern.

Strato hat leider da echt viele Baustellen im bereich DNS und Sicherheit. Nichtmal 2FA gibts da :(

Foto
1

Strato schreibt doch in seiner Doku recht eindeutig mit rotem Ausrufezeichen vorangestellt:


"! Bitte beachten Sie, dass Änderungen an DNS-Einstellungen aufgrund der dezentralen Namensserverstruktur unter Umständen erst 24 Stunden nach Aktivierung vollständig aktiv sind."

Foto
1

Ja, Änderungen dauern bis sich die Propagieren, aber ich hab ja nur von einer Zone auf die andere gewechselt. Beide Zonen hatten eine identische config. Das heißt irgendwo ist etwas kaputt gegeangen obwohl sowohl die config davor als auch die config danach funktionieren hätten sollen.


Ich konnte auch problemlos meine Domain neu veriferzieren in den Mailbox.org settings (TTL war auf 60s) gesetzt.

Foto
Hinterlassen Sie einen Kommentar
 
Dateianlage anfügen