Willkommen im User-Forum von mailbox.org
 

DNS Einträge bei Hetzner

3909942 hat dies geteilt, 20 Tage her
veröffentlicht

Liebes Forum,

ich versuche gerade für eine meiner Domains (im Erfolgsfall noch drei mehr) den Mail-Teil von Hetzner zu Mailbox umzuziehen und komme da nicht wirklich weiter. Die Validierung des TXT Eintrages hat geklappt, die MX Einträge auch. Allerdings sind bei Hetzner im DNS record management (noch) einige Einträge vorhanden, die offensichtlich mit E-Mail zu tun haben. Konkret ist das ein CNAME Eintrag, ein SOA und vier SRV Einträge. Kann / soll ich die alle löschen?

Zusätzlich gibt es noch einen TXT Eintrag mit dem Wert "v=spf1 +a +mx ?all", in dem zumindestes das Kürzel mx vorkommt.

D.

Antworten (9)

Foto
1

Hier gibt es Infos zu den von mailbox.org epfohlenen bzw. notwendigen Daten: https://kb.mailbox.org/de/privat/e-mail-mit-eigener-domain/spam-reputation-der-eigenen-domain-verbessern-mit-spf-dkim-und-dmarc


Der letzte Eintrag ist ein SPF-Eintrag. Den musst Du - ja nach Bedarf - durch den von mailbox.og ersetzen oder aber um den mailbox.org-Teil ergänzen (siehe Link).

Die anderen Einträge müsste man im Detail kennen um zu entscheiden, was mit ihnen passieren soll.

Foto
1

Danke! Aber dann ist das für mich eigentlich gestorben. Resp ich muss mich entscheiden, ob ich einfach bei Hetzner bleibe (funktioniert ja alles einwandfrei im Rahmen des Gebotenen) oder meine Mail-Adressen auf xxx@mailbox.org umstelle und die eigene Domain für Email aufgebe. Aber wenn ich zum Experten in DNS Konfiguration werden muss, um das sauber aufzusetzen, macht das doch keinen Sinn. So erhöhre ich meine Email-Sicherheit beim besten Willen nicht, da sind einfach zu viele Dinge, die falsch eingestellt werden können. Und der Witz an so einer Lösung ist ja die GEWISSHEIT, dass das am Ende auch alles korrekt konfiguriert ist. Ohne einen professionellen Konfigurations-Service (gerne gegen Gebühr) von Seite MBO ist das doch ein Murks.

Foto
1

Der Link von thgeiges ist eigentlich der Spezialfall, wenn Du fortgeschrittene Anti-Spam-Maßnahmen umsetzen willst. Die Basiskonfiguration ist hier beschrieben: https://kb.mailbox.org/de/business/e-mail-mit-eigener-domain/e-mail-adressen-der-eigenen-domain-nutzen#EMailAdressendereigenenDomainnutzen-Troubleshooting1–DNS-SettingsbeieinemProvider

Foto
1

Danke auch an Dich. An diese Basis-Konfiguration habe ich mich auch gehalten. Aktuell landen Mails auf die Adresse immer noch bei Hetzner, aber da sollte ich wohl erst mal einen Tag warten. Davon abgesehen sind da aber eben ein ganzer Haufen an Einträgen, von denen in der Knowledgebase nicht die Rede ist und die (zumindest laut dem Link oben) auch erst mal nix mit Spam zu tun haben. Dass die bei einer sauberen Konfiguration aber da verbleiben sollen, kann ich mir nicht wirklich vorstellen. Und an dem SOA Eintrag kann ich noch nicht mal was ändern.


cab4d72df15051ac40aed46289520d61

Foto
1

Ich habe gerade mal nachgesehen, bei mir sind es noch deutlich mehr Einträge. Wichtig sind ja aber erst einmal nur die MX-Einträge. Daher würde ich einfach mal 24 Stunden abwarten, bis das alle DNS-Server mitbekommen haben.

Ganz generell solltest Du Dich bei Fragen zu den zusätzlichen Einträgen aber eher an Hetzner als an mailbox.org wenden.

Foto
Foto
1

Alles im DNS was Mail betrifft und auf Hetzner verweist, muss raus. Dann muss das, was in den Hilfeseiten von mailbox.org steht, rein.


Die Einträge submission, imap, autoconfig, etc. sind meines Wissens alles Einträge für die Autokonfiguration von Emailclients. Da diese alle auf Hetzner verweisen, müssen die raus.

Leider erfordert die Einbindung eines externen Mailanbieters etwas DNS-Kenntnisse. Das ist aber bei allen Anbietern so, sobald du Domainhosting, Webhosting und Mailhosting trennst. Letztlich bekommst du hier im Userforum in der Regel Hilfe wenn etwas hakt. Wichtig ist folgendes: Die MX-Einträge sind für den Empfang relevant. Die anderen Einträge (spf, dmarc, dkim) sind wichtig, damit du beim Empfänger nicht (bzw. weniger wahrscheinlich) im Spam-ordner landest. Der Sicherheitsschlüssel ist nur einmalig notwendig, damit du bei mailbox.org den Alias mit der externen Domain einrichten kannst.

EDIT: Was man bei mailbox.org kritisieren könnte, ist der DMARC-Eintrag. Da hat mailbox.org selber einen anderen, als in den Hilfeseiten empfohlen wird. Mehr als die Vorschrift zur Quarantäne (oder Ablehnung) ist eigentlich nicht notwendig im Dmarc-Record. Wer will schon Reports lesen. Es macht meiner Meinung nach mehr Sinn, spf, dmarc und dkim auf einem der Testportale zu überprüfen, als dmarc ohne Regel (p=none) zu verwenden.

Foto
1

Vielen Dank für all die Hilfe! Mittlerweile läuft es, wie es soll. Der Support von Hetzner meinte am Ende auch, dass alle SRV-Einträge rausmüssen und den CNAME-Eintrag habe ich dann auch gleich gelöscht (obwohl dazu keine Ansage kam). Dass das so lange gedauert hat (inkl meiner Antwort hier) hat damit zu tun, dass meine Test-Mails um zu sehen, wo die landen, über eine Woche nach den DNS Änderungen weiter zu Hetzner gingen. Vielleicht wird da intern gecached, wenn der Absender (eine andere Domain von mir) halt auch bei Hetzner ist. Jedenfalls als das dann endlich nicht mehr der Fall war, sah ich erst, dass da schon seit mehreren Tagen einige Mails für die Adresse bei MBO lagen.

Also falls da jemand mal ähnliche Fragen / Probleme hat: alle DNS-Einträge, die irgendwie mit mail zu tun haben müssen raus und dann kann es ganz schön lange dauern, bis der Umzug wirklich durch ist.

Foto
1

Ich muss das leider zurücknehmen. Jetzt geht eine Mail an besagte Domain wieder zu Hetzner, obwohl seit einer Woche nichts in den DNS Einträgen noch zu Hetzner zeigt. Sowohl von einer anderen Adresse bei Hetzner wie auch von Gmail. Von meiner xxx@mailbox.org Adresse aus, landet die Mail an die selbe Adresse allerdings bei MBO!?


Dann sieht Apple Mail zwar die Ordner Struktur meiner MBO Inbox, die Ordner erscheinen aber alle leer (was sie nicht sind) und beim Versuch da Mails per IMAP reinzukopieren kommt die Fehlermeldung, den Ordner gäbe es gar nicht. Ganz schöner Murks das alles...

Foto
2

Ich würde die Probleme trennen. Als erstes würde ich nur noch den Webmailer verwenden, um die DNS-Problematik zu beheben. Auf https://dnschecker.org kannst du die MX-Server deiner privaten Domain anzeigen lassen. Da sollte exakt und nur das folgende erscheinen (Reihenfolge nicht relevant):

10:mxext1.mailbox.org.
10:mxext2.mailbox.org.
20:mxext3.mailbox.org.

Dann würde ich im Webmailer prüfen, ob du aus Versehen irgendwelche Filterregeln (z.B. Weiterleitung) eingegeben hast, und vergessen hast, zu löschen.

Dann wäre zu prüfen, welche Mails genau noch bei Hetzner ankommen, und welche zu Mailbox.org gehen. Voraussetzung ist natürlich, dass die MX-Einträge (s.o.) stimmen, und du die Mailadresse mail@eigene.domain bei Mailbox.org als (Haupt)alias eingerichtet hast. Sollten nur diejenigen Mails immer noch bei Hetzner landen, die auch von Hetzner verschickt wurden, dann hat Hetzner irgendwas langfristig gespeichert. Nimm einfach irgendeinen freemailer (gmail, web.de, gmx, Microsoft) und schicke dir Mails zu. Wenn die MX-Einträge korrekt sind, dann müssen die Mails bei mailbox.org landen.


Und nur noch zu meinem Verständnis, dass ich die Situation richtig einschätze: Du hattest ein Postfach mail@eigene.domain bei Hetzner, und das Postfach ist dort auch immer noch. Dann hast du dich bei mailbox.org registriert, und dein Mailbox.org-Postfach für die eigene Domain mail@eigene.domain eingerichtet (Alias hinzugefügt und MX-Einträge gesetzt). Jetzt verweisen die MX-Einträge auf mailbox.org, aber für mail@eigene.domain hast du sowohl bei mailbox.org als auch Hetzner ein Postfach.

Foto
1

Du hast Recht, das sind natürlich zwei unterschiedliche Probleme. Laut dnschecker sind die MX Einträge korrekt. Und ich habe jetzt auch noch mal versucht, die Dinge auseinanderzuhalten. Mails von Gmail landen tatsächlich bei MBO, während Mails von einer anderen Hetzner-Adresse weiter zu Hetzner gehen (die kann ich ja den Hetzner Webmailer mit dem alten Login nachwievor prüfen). Das scheint also ein Hetzner Problem zu sein.

Was Deine Verständnis-Frage angeht. Ich hatte mehrere Domains bei hetzner und wollte die evtl alle zu MBO umziehen, hab das aber fürs erste bloß mal mit einer gemacht. Deshalb kann ich von anderen Domains bei Hetzner auch nach wie vor Mails verschicken. Ich hoffe das klärt das auf?

Das andere Problem scheint ein Apple-Mail Ding zu sein. Thunderbird sieht die Ordnerstruktur und auch deren Inhalt bei MBO. Ist das ein bekanntes Problem mit Apple Mail? Das ist schon nicht gerade optimal.

Foto
2

Zum 2. Problem: Es ist m.E. kein grundsätzliches Apple-Problem. Ich habe mehrere mailbox.org-Accounts auf diversen Apple-Geräten (iMac, MacBook, iPhone, iPad) seit mehreren Jahren erfolgreich im Einsatz. Es gab nie Probleme, auch nicht bei iOS- bzw. MacOS-Updates. Ebenso meine Frau (Team-Account) und mein Sohn mit einem eigenständigen Account.

Foto
1

Ich kann nur für die Apple-Mail-App von iOS (also iPhone) sprechen. Damit habe ich seit mehreren Jahren kein Problem. Alles funktioniert wie gewünscht.

MacOS (also Laptops oder Computer von Apple) verwende/habe ich nicht.

Foto
1

OK, MBO account in den Apple System Preferences löschen und neu anlegen hat auch das zweite Problem gelöst (in macOS). Der Upload des Mail-Archivs via Apple Mail scheint auch zu klappen, aber das dauert wohl noch ein Weilchen. Danke euch beiden!

Gehört zwar eigentlich nicht hierher, aber mir ist nicht ganz klar, wie das mit der Unified Mail funktioniert. Eigene Archive pro Domain resp Alias anzulegen ist ja kein Ding, aber wie sieht das bei den gesendeten Mails aus? Kann man die auch trennen? Die Einträge in der KB zu Unified Mail sind sehr spärlich.

Foto
Foto
1

Hilfe zur Einrichtung auf Apple-Geräten findest Du hier:

zu iOS: https://kb.mailbox.org/de/privat/e-mail-artikel/einrichtung-mit-mail-app-fuer-ios

zu MacOS: https://kb.mailbox.org/de/privat/e-mail-artikel/e-mail-einrichtung-mit-der-e-mail-app-von-mac-os-x Die Darstellung gilt für MacOS vor Version 13, ist aber funktionell in Ordnung.

Ich würde auf alle Fälle die Einrichtung wie beschrieben manuell machen. Damit bin ich bisher immer gut gefahren. Und ich würde den Account auf Mac oder iPhone nochmal neu einrichten.

Foto
1

Ich habe ein ähnliches Verhalten wie Dein Problem bei Hetzner vor ein paar Jahren bei einem anderen Provider auch gehabt. Mails, die von einem Konto (auch von anderen Kunden) beim gleichen Provider kamen, wurden immer noch an das "alte Konto" zugestellt trotz geänderdem MX-Eintrag. Erst nachdem ich das Konto gelöscht hatte, das ich ja eigentlich dort auch nicht mehr benötigte, hörte der Spuk auf. Mails wurden offensichtlich im internen Netz des Providers "direkt" zugestellt und damit der MX-Eintrag missachtet. Kamen die Mails von außerhalb, wurden sie korrekt an das neue Konto beim anderen Provider zugestellt.

Foto
1

Für den Moment würde ich das Konto bei Hetzner ganz gerne noch so lassen um genau solche Sachen trouble-shooten plus die ganze Mail-Migration durchführen zu können und ich muss mir selber ja nicht andauernd mails schicken. Aber dann werde ich sobald alles zuverläßig läuft, das wohl auch so machen und alles bei Hetzner löschen.

Foto
1

Das beschriebene Verhalten ist meiner Meinung nach ganz normal und meines Wissens auch bei mailbox.org so. Als Beispiel: Du hast foo@bar.de bei mailbox.org und änderst die MX-Einträge weg von mailbox.org. Dann werden die foo@bar.de-Mails weiter an das eingerichtete Konto verschickt, ohne die MX-Einträge anzuschauen.


Das kann man sich vergleichbar wie mit einer Hauspost in Firmen/Behörden vorstellen. Wenn der Absender (hier der SMTP-Server) schon weiß, dass der Empfänger in der gleichen Firma ist, wird man den Brief nicht frankieren und per Post verschicken, nur dass er dann ein paar Tage später wieder am selben Ort eintrifft.

Foto
Hinterlassen Sie einen Kommentar
 
Dateianlage anfügen