Willkommen im User-Forum von mailbox.org
 

ActiveSync Push unter iOS instabil

6981546 hat dies geteilt, 3 Jahren her
bekannt

Hallo,

wenn ich unter iOS die Mailbox.org-Emails per Active Sync abhole bzw. per Push auf das iPhone kommen lasse, habe ich immer das Problem, dass die Push-Funktion nicht dauerhaft funktioniert.

Meistens bekomme ich nach öffnen der Mail-App auf dem iPhone für ca. 30 Minuten oder so die Mails gepusht, aber später dann nicht mehr. Wenn ich dann die Mail-App wieder öffne, werden die Mails geladen.

Ich habe es immer wieder mal ausprobiert und das Problem scheint sich nicht zu lösen.

Mich würde interessieren, ob auch andere Benutzer das Problem haben?

Gruß,

Mark

Beste Antwort
Foto

ActiveSync ist leider nicht immer ActiveSync. Jedes Smartphonebetriebssystem hat seine eigene mehr oder weniger vollständige Implementation davon. Bei manchen ActiveSync Implementationen fehlen einige Features vollständig, andere haben kleine Unterschiede z.B. im Zertifikatshandling oder dabei wieviele Wochen oder Monate in die Vergangenheit eine Synchronisation reichen kann. Hier kocht jeder Smartphonehersteller leider sein eigenes Süppchen - manche halten sich mehr, andere weniger an die Rezeptvorgabe von Microsoft.

Unsere iOS-Tests haben ergeben, dass sobald die Mail App nicht aktiv im Vordergrund war, Push irgendwann nicht mehr ging. Ab wann dies passiert ist nicht deterministisch, aber soweit wir das sagen können, immer nachdem über einen längeren Zeitraum (ca. >= 2h) keine neuen E-Mails auf dem Server eingetroffen sind.

Probleme mit ActiveSync sind Apple auch bekannt. Siehe:

https://discussions.apple.com/thread/6548202

https://discussions.apple.com/message/30214155#30214155

Aufgrund der internen Tests und der im Internet verfügbaren Informationen kommen wir zum Schluss, dass das Problem nicht bei OX / USM zu suchen ist sondern ein IOS/Apple Issue ist.

Wir können als einzigen Workaround, der in der Praxis tauglich ist, empfehlen:

Benutzer mit entsprechenden iOS Versionen (>= 8.1.2) sollten von Push auf Pull wechseln, da der Pull unabhängig von der jeweiligen Netzwerkinfrastruktur, Roamingeinstellungen und aktiver Mail App funktioniert.

Wir sind diesbezüglich mit Open Xchange in engem Kontakt und suchen natürlich auch auf unserer Seite nach Lösungen.

Kommentare (101)

Foto
1

Das wäre mir auch mein Anliegen. Das Thema EAS klappt gar nicht.

Foto
1

Gleiches Problem bei mir. Scheint wohl bei mehreren Leuten aufzutreten.

Foto
1

Ich kann es auch bestätigen. Auffällig ist es wenn man Ordner im Postfach angelegt hat und E-Mail automatisch verschoben werden. Es werden E-Mails teilweise erst dann angezeigt wenn man auf den Ordner klickt.

Foto
1

Zusätzlich zu den hier schon genannten Problemen ist mir auch aufgefallen, dass über EAS die Markierung von Nachrichten (Flags) nicht synchronisiert wird, sondern nur lokal auf dem Gerät erfolgt. Per IMAP klappt das problemlos über Gerätegrenzen hinweg.

Foto
1

Welche IOS Version setzt ihr ein? Bei mir funzt es seitdem mailbox.org existiert seit ein paar Wochen zum ersten Mal... :-)!!!

Ich nutze 9.2. Kurz nachdem ich unter Android die Meldung erhalten habe, dass mailbox.org eine Aktualisierung der Sicherheitseinstellungen anfordert (= Indiz dafür, dass auf dem Server die Version/Einstellungen aktualisiert wurden?), habe ich auf meinem iPhone satt IMAP mal wieder ActiveSync eingerichtet und seitdem funzt das wie die Wutz!!!

Ich hatte mich vor kurzem auch mal per Mail an das mailbox.org Team gewendet. Vielleicht wurde bei mir daraufhin was geändert? Bitte liebes mailbox.org Team: Lasst das bei mir so wie es ist... ;-)!

Zwischenzeitlich habe ich auch andere Mail Clients die unter IOS Activesync unterstützen getestet. Bei denen hat es mit dem Push auch nicht funktioniert, teilweise sogar noch weniger als mit der Apple IOS App.

Foto
1

Ich nutze das aktuelle iOS 9.2, habe das Problem mit dem nicht regelmäßig funktionierenden ActiveSync seit iOS 7. Ich hatte mich auch schon einmal an den Support gewendet. Lapidare Antwort: Deren Geräte funktionierten einwandfrei, kein Fehler feststellbar.

Foto
1

Kann denn jemand sagen ob das Problem unter Android oder iOS7 auch aktuell besteht?

Oder ob die Push-Funktion mit anderen OpenXchange oder Microsoft Exchange-Lösungen stabil läuft?

Foto
1

An die verschiedenen IOS Versionen die ich getestet habe, kann ich mich nicht mehr erinnern.

Android 5.0 (Medion Tablet): Kein ActiveSync Push

Android 6.x: Könnte ich bei Bedarf nachliefern.

Bei Android gibt es Alternativen, mit denen man das Problem umschiffen kann, da die IMAP Push unterstützen (z. B. K-@Mail)

Foto
1

Zusätzlich habe ich das Problem, dass die App "Mail" unter iOS 9.2 mir immer wieder neue Mails anzeigt obwohl sich keine neuen Mails im Postfach befinden.

Umgehungslösung: ActivSync-Zugang komplett löschen und neu anlegen.

Foto
1

Unter Android kann man eigentlich keine generische Aussage treffen wie gut EAS oder ähnliches funktioniert da teilweise die Hersteller den originalen Google EAS Code patchen und "verbessern".

Ich persönlich nutze für Kalendar, Kontakte und Aufgaben Caldav und Carddav und synchronisiere Emails via IMAP periodisch alle 15 Minuten stillschweigend. Von Push halte ich persönlich nichts, stört die Konzentration und ist daher wie alles andere was piept, bimmelt, vebriert oder benachrichtigt ausgeschaltet.

Würde ich Push wieder nutzen wollen würde ich die native "OX Mail" App nutzen, da ist kein EAS Code drunter und Android / iOS können nichts dran fummeln, funktioniert daher am "stabilsten" weils der schlankeste Stack ist vermute ich.

Daniel

Foto
1

Die OX Mail App pusht unter iOS leider nicht.

Foto
Foto
1

6981546 hat noch die Frage offen, wie das bei anderen Implementationen ist:

Zu anderen OpenXchange Installationen kann ich nichts sagen.

Es gibt zwar immer wieder Phasen mit Problemen, aber i. d. R. pushen Microsoft Exchange Konten zuverlässig. Viele Großunternehmen haben MS Exchange zusammen mit IOS Geräten im Einsatz. Ich selbst hatte mal ein Office365 Konto und das hat immer funktioniert.

Foto
1

Ich glaube auch das es an der Konstellation OX & EAS liegt. Hatte auch mit iOS 8 einen echten Exchange Account und das hat immer ordentich gepushed.

Foto
1

Bei mir funktioniert es derzeit perfekt. Auch wenn ich eine Mail auf

einem anderen Gerät gelesen habe, wird der Status auf dem iPhone

geändert und der Hinweis auf die neue Mail verschwindet in der

Mitteilungszentrale.

@ Mailbox.org-Team: Wäre toll, wenn das so bleiben würde! So macht das mit mailbox.org richtig Spaß...

Gibt es denn Nurtzer, die IOS 9.X einsetzen und Probleme mit Push unter ActiveSync haben? Das wäre ja merkwürdig....

Foto
1

Welches iOS 9.X nutzt Du denn? Ich habe es seit 9.2 raus ist ehrlich gesagt nicht mehr versucht. Seit iOS 8 hat das nicht mehr richtig geklappt. Ich habe iOS 9.2 mit einem 6s. Ich verfolge auch die Apple Supportforen wo immer wieder das Problem auftaucht. Tagsüber (gefühlt) klappt das mit dem push aber über nacht bekomme ich die Mails erst wenn ich die Mail App öffne. Ich habe erst gedacht, das sich meine Fritzbox abschaltet wenn kein Gerät mehr connected ist oder so aber ich kann keine Einstellung finden....

Foto
1

Bei mir ist es auch ab und zu über Nacht weg. Ich habe keine Fritzbox, es kann also daran auch nicht liegen. Muss wohl was mit der Implementierung insgesamt zu tun haben, schätze ich.

Foto
Foto
1

Ja, die gibt es. Mich zum Beispiel :) Habe ich ja schon vor einer Woche hier gepostet, siehe weiter oben. Das Problem hat meiner Meinung nach nichts mit dem iOS-Versionen zu tun, denn es taucht immer wieder auf. Meistens funktioniert es zwar, aber eben nicht immer. Und ich kann nicht nachvollziehen, warum nicht. Es ist einfach nur ärgerlich. Accounts mit "richtigem" Exchange ActiveSync wie etwa mein beruflicher Account auf dem iPhone haben dieses Problem nicht. Die sind zuverlässig.

Foto
1

@Mailbox Support: Nutz Ihr denn auch die aktuellste Version von EAS? Die aktuellste laut MS ist die 16.0, die auch Kalender Probeleme etc behebt!

Foto
2

Ich nutze 9.2.

Das ist doch jetzt eine Sache, bei der ich eine Reaktion seitens der Admins erwarte.

Foto
1

Ich sehe da auch Handlungsbedarf bei Mailbox.org..

Ich werde es aber aktuell mal wieder testen. Mein letzter Test ist ca. 6 Monate her

Foto
1

Moin! Gibt es ein Update zum Thema EAS? Habt Ihr mal getestet ob es mit 9.2(.1) besser geht?

@Mailbox.org Support: Wie sieht es mit der Info bzgl. der EAS Version aus?

Der Support & Peer sind bei jedem Thema aktiv nur bei diesem nicht... ; ) Das ist schon ein Ding was mir am Herzen liegt. Hatte einen super Hosted Exchange Anbeiter bin dann aber wegen dem überzeugenden Gesamtpaket und dem motivierten Team zu Mailbox.org gewechselt. Leider wird hier ein Feature angeboten des meines Erachtens aber nicht wirklich geht... Nich böse sein.

Foto
1

Ich teste es jetzt seit vorgestern mit iOS 9.2.1 und bisher läuft es sehr stabil...ich werde wieder berichten

Foto
1

Auch nachts? ; ) Da hatte ich so meine Probleme...

Foto
Foto
1

nachts gucke ich selten auf meine mails :)

aber morgens habe ich bisher keine Probleme gehabt...aber sind ja auch erst zwei Tage

Foto
1

Nicht? Das ist ja ein Ding! ; ) Ich hatte das Phänomen, das nachts halt keine Mails angekommen sind. Wenn ich dann die Mail App geöffnet habe, sind die alle eingetrudelt.

Foto
Foto
1

Wenn ich bei mir die Mail App immer mal wieder gentuzt habe oder alle paar Stunden Mails eingetroffen sind, dann hat es auch immer funktioniert. Wenn ich aber z. B. über Nacht die Mail App nicht genutzt habe und auch keine Mails eingetruddelt sind, dann wurden am Morgen bis zum nächste Öffnen der App keine Mails zugestellt.

Danach ging es dann erst mal wieder, bis zum nächsen Zeitraum in der es keine Mail Aktivitäten gegeben hat.

Das Verhalten ähnelt dem von me.com (Apple mail) von vor ca. 5 Jahren.

Foto
1

Aktuelles iOS und trotzdem Probleme mit Push. Nicht nur Nachts, sondern auch Tagsüber.

OX bekommt die EAS Unterstützung einfach nicht wirklich gebacken. Glaube auch nicht, dass da in naher Zukunft sich was dran ändern wird.

Wer vollen Push Support will muss dann leider wohl zur MS Variante greifen. Schade.

Foto
1

Das war bei mir bis dato auch so. Selbst mit Office 365 klappt es auf dem Iphone gut.

Foto
Foto
1

Wir sind diesbezüglich mit den Programmierern im Gespräch und treffen ein paar Vorbereitungen um das auch besser debuggen zu können. Das ist schwer nachvollziehbar UND es ist auch so, daß es da durchaus sehr viel "zickige und nicht standard-konforme Implementierungen" gibt, die sich ihrerseits komisch verhalten und man dieses nur nach und nach durch Fehler und Reverse-Engineering herauskriegen und "workarounden" kann.

Ich habe allerdings schon jetzt eben eine kleine Änderung im Linux-Kernel vorgenommen, die dieses Problem eventuell positive beeinflussen oder sogar ganz lösen könnte. Ich würde mich freuen, wenn's dazu die nächsten Tage nochmal Feedback gibt ob das noch besteht, oder vielleicht sogar nicht mehr.

Feedback dann auch gerne konkret mit Datum/Uhrzeit, damit wir in die Logs schauen können.

Foto
1

Hallo Peer, vielen Dank für die Info! Ich werde das mal die nächsten 2 Wochen testen und Feedback geben. Klasse das Du auch schon etwas verändert hast. Danke!

Foto
1

Schön zu hören, dass sich etwas tut.

Ich werde auch berichten wenn Probleme auftreten.

Danke!

Foto
1

Super!!!

Foto
1

...obwohl ich mir jetzt schon was Sorgen mache. Aber im Sinne des Allgemeinwohls...

;-)

Foto
1

Aber genau deswegen sind wir doch Kunde bei dieser tollen Firma! :) DAUMEN HOCH!

Foto
1

Also heute über Nacht hat mein iPhone die Verbindung verloren.

Ich habe gegen 06:30Uhr zunächst keine Notification gehabt. Dann habe ich die Mail-App geöffnet und manuell aktualisiert und es wurde eine Mail von 3:39 Uhr angezeigt.

Foto
1

Das passt ja zu meiner Beobachtung. Siehe mein Post ganz unten. Das Iphone geht in Standby und kappt die WLAN Verbindung. Hat Du eine gute mobile Verbindung? Ich versteh nur nicht warum das Tel dann nicht diese nutzt? ABER: Aktiviere mal Itunes WLAN-Sync in den Einstellungen. Nach mehreren Aussagen wird die WLAN Verbindung so aktiv gehalten. Ich habe das gestern Abend gemacht und bis dato kamen die Mails durch. Eventuell hilft es. Ansonsten kann ich nur bestätigen das bei aktiver mobiler Verbindung bis dato auch alles läuft.

Foto
1

Weil ich die Info wichtig finde und nicht zum Ärgern: Bei mir funktioniert es noch.

Wird eure Internetverbindung nächtens vom Provider oder der Fritzbox automatich getrennt? Bei Exchange macht das keine Problem aber ob es vielleicht daran liegen könnte?

Foto
1

An meiner WLAN-Verbindung liegt es denke ich nicht. Die Verbindung ist konstant vorhanden. Sonst hätte ich ja auch tagsüber Probleme und Push-Nachrichten von anderen Apps kommen an. Nebenbei habe ich auch keine FritzBox

Foto
1

Also bei mir scheint es nun zu klappen. Auch mit WLAN. Eventuell war meine Vermutung dann doch nicht korrekt. Aber versucht doch das mal mit dem iTunes WLAN Sync anschalten.

@Peer: War Deine Kernel bastelei am Ende die Lösung? Was hast Du verändert??

Foto
Foto
1

Schön zu lesen. Jedoch fühlt sich das mehr und mehr nach zahlender BETA-Tester an Stelle von Kunden an.

Wenn man Features einführt, wofür man auch Geld zahlt, sollten diese wenn möglich bitte auch laufen. Ansonsten kann man ja einen öffentlichen Beta-Test draus machen, der kostenfrei ist.

Foto
1

Hmm, also ein Großteil der erwähnten Bugs liegt in der Non-Standard-konformen Implementierung, beispielsweise in IPhone & Co. Da sind Kunden durchaus oft zahlende Beta-Kunden, wenn Du das so formulieren willst. Wenn der Rest diese Bugs debuggen und dann "Gegenprogrammieren" muß stellt sich etwas die Frage, ob der Hund mit dem Schwanz wedelt oder andersherum.

Ansonsten kann ich gerne öffentlich sagen, daß es -- bei aller QA und monatelangen Tests bei uns und anderen -- IMMER Fehler und NIE fehlerfreie Software geben wird und kann. So ist das leider seit Windows 95 so.

Anders als früher gibt es heute nicht ein Betriebssystem und eine Applikation, sondern Hunderte von Client-Implementierungen und diese dann nochmal in den verschiedensten Versionen. Es IST heutzutage unmöglich alles gegen alles zu testen. Probleme, die auftreten, liegen in aller Regel immer in dem Zusammenkommen von zwei Ereignissen auf beiden Seiten. Es ist ja nicht/nie so, daß es generell nicht geht und damit offensichtlich ist.

Foto
1

Active Sync ist doch eine der Hauptmerkmale des Tarifs Mail XL - und iPhones sind sozusagen Standard im mobilen Bereich, bzw. mit welchem anderen Standard soll denn mobil Active-Sync genutzt werden?

Und ja, ich verstehe auch was QA etc. ist und was es gerade im Software-Bereich bedeutet/bewirkt und das es hier immer wieder Dinge gibt, die durchrutschen. Darum geht es ja auch gar nicht.

Ein funktionierendes Active-Sync könnte man schon erwarten. Die Probleme gibt es ja auch schon etwas länger.

Ein nicht oder nur eingeschränkt funktionierender bzw. nicht geupdateter OX Drive Client für iOS bzw. Mac OS sind andere Dinge welche hier nicht zum Thema gehören, aber durchaus auch standard-konforme Tools.

Ich finde Euch super, eure Arbeit klasse, jedoch hakt es mit dem OX leider doch sehr - und das finde ich sehr schade.

Foto
1

Wir wollen das hier ja jetzt nicht zu einer Grundsatzdiskussion ausarten lassen. Das ist nicht Sinn und Zweck. Ich bin zu 99% zufrieden mit OX nur das EAS Thema "drückt" mich etwas. Ich teste nun aber. Ansich fine ich auch das Forum super und transparent bzw mit den Problemen wird nun transparent umgegangen. Hätte man ja nicht machen müssen. Schliesslich öffnet man hier ja die unzähligen Probleme der Allgemeinheit. Für mich ein echter Vertrauensbeweis! Danke an das Team! Harren wir der Dinge. Wir wollen einerseits immer die neusten Verschlüsselungen haben und alles ganz privat und zum anderen auch noch super konfortabel.Ich verstehe da Peer das man sich nicht zerteilen kann. Es kommen so oft neue Sachen, da beschwere ich mich nicht.

Foto
Foto
1

Ich habe etwas getestet. Iphone 6s mit iOS 9.2.1. WENN: Das Iphone rein mit mobilem Datenetz verbunden ist rennt ActiveSync wie es soll! Also alles ok. WENN ABER: Das Iphone Zuhause bei mir mit meinem WLAN verbunden ist (Fritzbox) dann kommen nach ca 30 min keine Mails mehr als Push durch. Erst wenn ich das Tel per Homebutton aufwecke. HEISST: Wenn mit WLAN verbunden schaltet das WLAN im Standby irgendwann ab!? Warum wird dann aber nicht auf die vorhandene mobile Verbindung zurückgegriffen? Ich kann mich nicht erinnern ab wann das technisch so ist (das mit dem WLAN abschalten). Ist alles nur ne Theorie von mir. Wie ist es bei Euch? Ähnliche Erfahrung?

Foto
2

Bei mir funktioniert Push jetzt seit drei Tagen mit iOS 9.2 bzw. 9.2.1 zuverlässig.

Bei meinen vorherigen Testläufen war es nie auch nur annähernd so gut.

Foto
1

Nach kurzem Testlauf mit ActiveSync habe ich recht zügig auf die Kombination IMAP/CalDAV/CardDAV gewechselt. Funktioniert wesentlich zuverlässiger, und bei Familienaccounts ist der Vorteil, dass man dann auch den Kalender anderer sehen kann (in meinem Fall den meiner Frau), und umgekehrt.

Foto
1

Aber mit IMAP leider kein Push, sondern nur IMAP Idle.

Foto
1

Push ist für Mailjunkies ;)

Foto
1

Mag sein. Gibt aber auch Anwendungen/Fälle, wo man direkte Mail-Benachrichtigungen braucht.

Außerdem spart Push Akku ;-)

Foto
1

Funktional:

Ich verwende nach Testen aller Optionen das exakt gleiche Setup wie Alexander, das ist die beste Kombination aus Funktionalität und Stabilität, wie zu erwarten bei offenen erprobten Protokollen wie IMAP, SMTP und DAV.

Netzpolitisch:

Microsoft hält die Hände über die EAS Patente, wenn Microsoft es möchte kann man eine Lizenz kaufen um an die Doku ranzukommen oder sich auszutauschen, ansonsten muss man selber sehen wo man bleibt. Es kommt nicht von ungefähr das EAS immer wieder hakt, außer bei den Microsoft hauseigenen Lösungen, welch Wunder. Sollte man auf so einen propertiären Standard und so eine Praktik unterstützen, ich denke nein.

Foto
1

M. E. sollten wir hier keine politischen Diskussionen führen.

ActiveSync ist seit Jahren ein offizielles Feature von Mailbox.org. Viele Kunden werden dieses Produkt u. a. deshalb gewählt haben, weil sie eine Push Funktion unter IOS wünschen, was IMAP nun mal nicht bietet.

Ich denke es gibt daher ein berechtigtes Interesse, dass AcitiveSync funktioniert.

Da die Kunden hier im Forum über aus kooperativ sind, sollte es gemeinsam gelingen ActiveSync ans Rennen zu bekommen☺

Foto
Foto
1

Moin, neuer Teststatus: Seit Donnerstag bis dato keine Probleme mehr mit Push. Die Mails werden zuverlässig zugestellt, auch nachts. Kein Nachladen etc. Das einzige was ich bei mir am Iphone gemacht habe ist den iTunes WLAN Sync zu aktivieren. Mehrere Quellen im Netz sagen, das damit das Problem der WLAN Trennung im Standby behoben wird. Akku hält auch ganz normal. Iphone 6s mit iOS 9.2.1

Gruss!

Foto
1

Ich habe heute morgen wieder das gleiche Problem wie bisher gehabt.

Um 3Uhr hätte ich eine Mail bekommen sollen, die aber erst geladen wurde, als ich gegen 8Uhr die Mail-App geöffnet habe,

Itunes WLAN-Sync habe ich schon immer aktiviert gehabt.

Die ersten paar Tage war ich auch zuversichtlich, aber jetzt läuft es gerade wieder genau so unzuverlässig wie seit geraumer Zeit

Foto
1

Was passiert denn, wenn du WLAN über Nacht deaktiviert? Klappt es dann auch nicht?

Foto
1

Werde ich heute Nacht mal testen

Foto
1

Ich finde es nach wie vor merkwürdig, dass es bei einigen funktioniert und anderen nicht. Jedenfalls dann, wenn alle einen Tarif mit ActiveSync gebucht und alle die gleichen serverseitigen Einstellungen haben...und natürlich den gleichen aktuellen IOS Client nutzen.

Vielleicht sollten auch andere mit Problemen mal WLAN ausschalten, vorausgesetzt sie haben ein brauchbares Mobilfunknetz zur Verfügung.

Foto
Foto
1

Ich würde auch gerne ActiveSync nutzen (derzeit nutze ich IMAP), jedoch lief es bei meinem letzten Test (schon ein paar Tage mehr her) nicht so wirklich rund. Wäre super wenn da noch mal nachgebessert wird.

Foto
1

Hatte heute Nacht mal WLAN aus. Ergebnis: Gleiches Problem

Mails wurden heute morgen nicht mehr gepusht.

Wie bereits gesagt: Andere Notifications kommen bei WLAN-Verbindung ja auch an.

Foto
1

Hmm ..

Und was ganz "blödes": Das OSX Profil löschen, Neustart und neu anlegen?

Du bist aber auf der aktuellen IOS Version?

Foto
1

Ich meine natürlich das openXchange Profil

Foto
1

Bei mir heute morgen das gleiche Problem. Aktuelle iOS Version iPhone 6s, Profil wurde bereits mehrfach neu angelegt. Andere Push Dienste (MS Exchange von der Arbeit z.B.) laufen problemlos.

Foto
1

Update von mir: Nach einem guten Wochenende mit voller Funktion habe ich seit Montag wieder Aussetzer in der Zustellung. Diesmal auch wenn ich mobiles Netz habe. Ich denke, ich werden wieder auf imap umstellen.

Foto
1

Bei mir heute bisher gar keine Push-Funktion. Die Tage davor aber recht zuverlässig. Auf IMAP umstellen mag ich nicht, ich habe den Tarif Mail XL extra wegen ActiveSync gewählt.

Foto
Foto
1

Gibt es denn seitens des Supports was Neues?

Foto
1

Würde mich auch mal interessieren, kann das Mailbox Team dazu bitte noch mal was sagen? :)

Foto
Foto
1

Wir sind mit den Codern in Kontakt und suchen Wege das zu debuggen. Das ist halt nach wie vor reichlich unspezifiziert und unklar. Wir sind da aber dran.

Foto
1

Neuigkeiten?

Foto
Foto
1

Gibt es inzwischen was neues? Habt ihr was gändert?

Leider funktioniert die Aktualisierung des Nachrichten Status ungelesen/gelesen auf meinem iPhone nicht mehr zuverlässig (ca. 70% funktionieren, 30% nicht): Mails die ich in der Web Anwendung o. auf einem anderen Gerät gelesen habe, werden auf dem iPhone nicht mehr auf gelesen gesetzt. Ich meine das Problem tritt besonders am Morgen auf.

Foto
1

Derzeit geht es garnicht mehr. Nicht mal ein Neustart hilft. :-(

Foto
1

Funzt wieder!!!

Bitte nich' mehr anpacken! ;-)

Foto
Foto
1

@ mailbox.org-Team: Die Push-Mail Zustellung der Mails funktioniert zu nahezu 100% auf meinem iPhone mit 9.2.1.

Die Aktualisierung des ungelesen/gelesen-Status funktioniert mal, dann wieder garnicht. Macht ihr da was? Wisst ihr was da los ist?

Foto
1

Vom Mailbox Team gibt es hier (und in so einigen anderen Themen) seit Tagen/Wochen keine Rückmeldung mehr, obwohl mehrfach explizit darum gebeten wurde. Das finde ich persönlich sehr enttäuschend. Würde ja sogar reichen wenn man mal ein kurzes Statement abgibt, dass es noch in Prüfung/Arbeit ist, aber stattdessen kommt gar nichts.

Foto
1

Das ist schade, weil es nach wie vor ärgerliche Baustellen gibt. Über mangelnde Geduld seitens der Kunden, kann man sich m. E. nicht beschweren. Das z. B. ActiveSync nicht richtg funktioniert, ist schon seit den Anfängen von mailbox.org der Fall.

Foto
1

Bei mir funkioniert es leider nicht zuverlässig auf dem iPhone. Die E-Mail über einen neuen Kommentar von gerade sind bei mir auf dem iPhone nicht angekommen

Foto
1

Die Frage ist für mich, ob das an deinem Handy liegt o. an OX. Bei mir geht Push ja (meistens).

Vielleicht testest du mal Hosted Exchange und guckst, ob es dann funktioniert. Es gibt da kostenlose Angebote mit begrenzter Laufzeit am Markt.

Generell ist das Thema Push-Mail immer was schwierig. iCloud aktualisiert den Mail-Status garnicht und Apple hatte vor Jahren auch massive Probleme mit Push. Auch unter Exchange hatte ich mal Probleme. Aber das das garnicht geht... Immerhin ist ein iPhone ja eine relativ standardisierte Plattform.

Foto
1

Bei mir geht Push ja auch, aber nicht immer, also nicht zuverlässig :)

Foto
1

"Vom Mailbox Team gibt es hier (und in so einigen anderen Themen) seit Tagen/Wochen keine Rückmeldung mehr, obwohl mehrfach explizit darum gebeten wurde."

Ich war letzte Woche beim Webcast dabei. Dort wurde gesagt, dass das Forum den Nutzern die Möglichkeit bieten soll sich untereinander zu helfen. Ich denke, dass man sich damit eine Entlastung des Support erhofft.

Bei Apple ist das z. B. auch nicht anders. Nichtsdestotroz gibt es insbesondere viele kleine Firmen und auch große, wie z. B. Microsoft, die Experten in das Forum schicken.

Ich finde es wichtig, dass sich das mailbox.org oder das OX Team stärker engagiert. Schließlich funktionieren viele Features bei OX seit langer Zeit nicht, die in der Produktbeschreibung explizit angegeben werden.

Bei mit funktionieren weder CardDav noch CalDav (Erinnerungen) und die ActiveSync Synchronisation funktioniert nicht wirklich zuverlässig.

Foto
1

Einfach auf *DAV umstellen und IMAP nutzen, fertig. Steht auch irgendwo ganz vorne im Topic.

Dann

bimmelt das Handy eben nur alle 15 Minuten, aber es bimmelt weil

stabile OpenSource Standards verwendet werden statt propertiären

Microsoftz Protokollen die momentan weder mit Google, Apple oder

irgendwem anders außer MS selbst kontinuierlich funktionieren.

Problem gelöst und dann in Ruhe abwarten, auch wenn entspanntes Abwarten bei erste Welt Problemen nicht typisch deutsch ist ;-)

Foto
2

Ich möchte ActiveSync und möchte das bekommen, was ich gekauft habe.

Grundsatzdiskussionen über OpenSource, Microsoft usw. spielen keine Rolle.

Foto
1

Dein Wunsch wird die Realität nicht verändern.

Google, Apple, mailbox.org und alle anderen würden sich freuen wenn der Standard 100 % stabil funktionieren würde oder gar zu einem offenen Protokoll gemacht würde. Möchte Microsoft aber nunmal nicht.

Foto
2

Das hat recht wenig mit Wunsch zu tun. Hier wird ganz klar mit ActiveSync in der Produktbeschreibung geworben und genau dafür zahlt man u.a. Geld. Nicht für ActiveSync dass vielleicht funktioniert. Denn Möglichkeit X anzubieten und hinter zu sagen "das funktioniert eigentlich nicht so richtig, nehmen Sie doch lieber Y und Z" ist nicht so ganz super gelöst.

Foto
1

Hoffe, dass der Support hierzu bald mal etwas schreibt. Wie in vielen anderen Threads ist es sehr sehr ruhig geworden seitens Support-Team-Antworten.

Schade eigentlich - da es fast alles Dinge sind, wo User sich selbst nicht weiterhelfen können.

Foto
Foto
1

Also bei mir läuft ActiveSync unter iOS 9.0.2 relativ stabil. Manchmal (nicht häufig, aber es kommt vor) habe ich Probleme mit der gelesen Markierung und dem Löschen von Mails. Ich würde sofort auf ActiveSync verzichten, wenn MailBox IMAP mit Push Support anbieten würde. Das wäre für mich viel wichtiger, als der Versuch dieses ActiveSync stabil zu bekommen. Ich denke, wenn es einfach zu lösen wäre, dann hätte man das Problem bereits längst aus der Welt geschafft. Scheint aber doch etwas komplizierter zu sein.

Foto
1

IMAP mit Push-Support wird bereits angeboten, läuft unter OSX mit OSX Mail auch ohne Probleme. Aber meines Wissens nach unterstützt iOS kein IMAP mit Push

Foto
1

ActiveSync funktioniert recht zuverlässig. ich schätze mal, dass die Mehrheit der DAX Unternehmen Exchamge mit ActiveSync einsetzen und die können es sich schlicht und einfach nicht leisten, dass das Mail System nicht zuverlässig funktioniert.

Foto
1

Das was 6981546 schreibt stimmt so nicht. IMAP mit Push wird von mailbox.org noch nicht angeboten - es sei denn, ich hätte was verpasst.

iOS unterstützt IMAP mit Push schon (siehe iCloud oder Fastmail als Anbieter) - nur eben auf eine andere Art und Weise.

Foto
1

Ich finde zwar auch keine offizielle Meldung zu IMAP und Push finden, aber ich kann nur sagen dass ich mit OSX Mail die E-Mails gepusht bekomme. Funktioniert scheinbar mit dem IDLE-Befehl

Kleiner Zusatz:

https://discussions.apple.com/thread/4362320?start=15&tstart=0

Der Beitrag ist zwar schon älter, aber scheinbar unterstützt iOS es noch nicht bei IMAP (iCloud ist ja hier differenziert zu betrachten)

Zweiter Zusatz :) :

https://www.maxmasnick.com/2015/07/17/fastmail-push/

Scheinbar geht es doch, aber nicht mit IDLE

Foto
2

Ok. Ich habe mir die Thematik auch mal angesehen. Der IDLE-Befehl ist für Smartphones mit Akku uninteressant. So wie ich das verstehe, musste Fastmail einen Push-Support bei Apple beantragen und diesen dann implementieren. Es wäre echt toll, wenn es das für MailBox auch geben würde. Es klingt für mich allerdings relativ aufwendig und ich habe vollstes Verständnis, wenn diese Funktion nicht morgen zur Verfügung steht.

Foto
Foto
1

ActiveSync ist leider nicht immer ActiveSync. Jedes Smartphonebetriebssystem hat seine eigene mehr oder weniger vollständige Implementation davon. Bei manchen ActiveSync Implementationen fehlen einige Features vollständig, andere haben kleine Unterschiede z.B. im Zertifikatshandling oder dabei wieviele Wochen oder Monate in die Vergangenheit eine Synchronisation reichen kann. Hier kocht jeder Smartphonehersteller leider sein eigenes Süppchen - manche halten sich mehr, andere weniger an die Rezeptvorgabe von Microsoft.

Unsere iOS-Tests haben ergeben, dass sobald die Mail App nicht aktiv im Vordergrund war, Push irgendwann nicht mehr ging. Ab wann dies passiert ist nicht deterministisch, aber soweit wir das sagen können, immer nachdem über einen längeren Zeitraum (ca. >= 2h) keine neuen E-Mails auf dem Server eingetroffen sind.

Probleme mit ActiveSync sind Apple auch bekannt. Siehe:

https://discussions.apple.com/thread/6548202

https://discussions.apple.com/message/30214155#30214155

Aufgrund der internen Tests und der im Internet verfügbaren Informationen kommen wir zum Schluss, dass das Problem nicht bei OX / USM zu suchen ist sondern ein IOS/Apple Issue ist.

Wir können als einzigen Workaround, der in der Praxis tauglich ist, empfehlen:

Benutzer mit entsprechenden iOS Versionen (>= 8.1.2) sollten von Push auf Pull wechseln, da der Pull unabhängig von der jeweiligen Netzwerkinfrastruktur, Roamingeinstellungen und aktiver Mail App funktioniert.

Wir sind diesbezüglich mit Open Xchange in engem Kontakt und suchen natürlich auch auf unserer Seite nach Lösungen.

Foto
2

Die verlinkten Probleme basieren auf einer alten iOS 8 Version, wo die Probleme am Ende behoben wurden - das sollte man als Grund nicht unbedingt hier verlinken.

Neben OX Active Sync habe ich auf meinen iOS Geräten parallel noch weitere MS Exchange Active Sync Accounts laufen - diese im Gegensatz zu OX ohne Probleme (und die Probleme sind bei OX ja nicht nur das Push sondern noch viel Größer! Formatierung Umlaute, teilweise nicht anzeigen von Nachrichten, div. Kalenderbugs usw.).

Man sollte überlegen ActiveSync seitens OX ganz von der Feature-List zu streichen, wenn es so viel Probleme macht bzw. in vielen Punkten streikt.

Wenn man liest, dass es supported wird, geht man von aus, dass es auch klappt.

Für mich war die ActiveSync-Thematik einer der Hauptgründe, warum ich mich für mailbox.org entschieden habe.

Aber trotzdem Danke, dass es seitens des Support mal eine Antwort hierzu gab/gibt.

Foto
1

Da kann ich dem Den zu 100% zustimmen!

Foto
1

Wir brauchen ActiveSync nicht von der Featureliste streichen, denn ActiveSync funktioniert (mit anderen Herstellern, die das ihrerseits sauber implementiert haben). Wenn ich einen Client mit kaputtem IMAP habe kann ich auch nicht hingehen und sagen, mailbox.org (oder ein beliebiger anderer Provider) hätte kein IMAP im Angebot.

Tut mir ja auch alles leid, aber das Thema ActiveSync wird bei Apple umfangreich diskutiert und ist dort eben auch alles andere als unproblematisch und bugfrei bekannt.

Foto
Foto
1

Scheint tatsächlich ein iOS Problem zu sein.

Push funktioniert bei mir immer eine Weile, dann nicht mehr. Sobald ich dann in die Mail App gehe und einmal von Hand syncronsiere geht es wieder ein weilchen.

Apple scheint angeblich das Problem zu kennen:

https://discussions.apple.com/message/30214155#30214155

Foto
2

Mal ne Rückmeldung: Iphone 6s mit iOS 9.3.2 (aktuellstes). EAS Einstellungen über den neuen Autoconfiguration Wizard auf den Telefon installiert. Mail Push läuft seit 5 Tagen super, alles andere auch. Kein Unterschied mehr zu einem echten Exchange Account zu merken. @mailbox habt ihr nochwas gedreht am EAS??

Foto
1

Es gibt immer wieder kleinere Updates hier und da; mit sind aber keine Changes im Bereich ActiveSync hier bekannt. Es spricht mehr dafür, daß Apple hier das Protokoll verbessert hat.

Foto
Foto
1

Eines vorweg: Ich habe momentan nur einen Probe-Account. Ich glaube aber nicht, dass dort das Problem liegt. Auf dem iOS gerät läuft die momentan aktuelleste Version (iOS 10.2).

Bei mir stellt sich die Situation auch so dar: Mails werden nicht vernünftig auf das gerät mit ActiveSync gepusht. Bei anderen Anbietern funktioniert dies aber... Es kann natürlich sein das Apple ActiveSync fehlerhaft integriert hat. Dennnoch funktioniert es bei anderen Anbietern und für mich war dieses einer der ausschlaggebenden Punkte Ihren Dienst zu testen und hoffentlich auch zu nutzen.

Es wäre schön wenn zumindest nach einer Lösung gesucht würde.

Liebe Grüße

Foto
1

Ich hab leider das gleiche Problem.

Kann aber bestaetigen das es auch mit anderen Anbietern (Firmenhandy und outlook.com konfiguriert mit activesync am iPhone) zu Abgleichsproblemen kommt.

So ist das mehr oder weniger unbrauchbar.

Wenn ich outlook.com als outlook Konto am iPhone einrichte (also ohne activesync) dann klappt der Push wirklich immer.

Foto
1

Ich teste ebenfalls grade mailbox.org und bekommen keine Nachrichten gepusht, obwohl das Konto korrekt eingerichtet und alle Ordner zum Syncen aktiviert wurden. Ich benutze Android 6.0.1 auf Cyanogenmod-Basis. Würde sehr gerne auf mailbox.org umsteigen, und funktionierender Push ist essentiell dafür.

Foto
2

Push via ActiveSync hakt leider öfters und es wird in div. abständen auch mal komplett neu gesynct (Achtung: Mobilfunk-Datenpläne).

Mit IMAP läuft es - da gibt es aber keinen echten Push.

Foto
2

Ich habe es grade noch einmal getestet: Mails, die im Posteingang landen, werden nach 10 Minuten aufs Handy gepusht. Mails, die per Regel in Unterordner sortiert werden, kommen gar nicht an. Sync für Unterordner ist aktiviert. So ist das Ganze leider unbrauchbar.

Foto
Foto
1

Das Problem besteht leider weiterhin.

Ich vermute es liegt am iPhone?