Willkommen im User-Forum von mailbox.org
 

Dokumentation zum SMTP Port ist uneindeutig?

5504749 hat dies geteilt, 3 Jahren her
kein Problem

Kommentare (29)

Foto
1

Mailbox.org unterstützt für SMTP sowohl Port 465 (SSL/TLS) als auch Port 587 (STARTTLS), sind also beide Anleitungen möglich.


Wenn man die Wahl hat, sollte man wohl SSL/TLS (Port 465) bevorzugen, siehe Vergleich von STARTTLS und SSL/TLS im Privacy-Handbuch.

Foto
1

Danke für die Antwort, hat mir sehr weiter geholfen!


Trotzdem sehe ich noch ein Problem mit der Dokumentation da nicht klar ist was für welchen Port geeignet ist, unter sonstige Mail Programme würde ich mir wünschen das alle Optionen da stehen, die auch zur verfügung gestellt werden

Foto
1

Wahrscheinlich gehen die Schreiber der Doku davon aus, dass das ja alles klar in irgendeinem RFC definiert ist:


Port 465: SMTP mit SSL/TLS

Port 587: SMTP mit STARTTLS

Foto
Foto
1

p, li { white-space: pre-wrap; }


Richte ich SMTP bei meinem Mail-Client (KMail) so ein: Port 465 - TLS

so bekomme ich diese Fehlermeldung beim Sendeversuch:

"Failed to transport message. smtp.mailbox.org Failed to store result in item. Item query returned empty result set"


Wenn ich die Autodetect-Funktion für die SMTP-Konfiguration nutze, wird dagegen diese Einstellung vorgenommen: Port 25 - TLS

Damit funktioniert das Senden von Mails einwandfrei, obwohl nicht dokumentiert(?).


?!

Foto
2

Beoi 465 bitte "SSL" angeben, nicht TLS oder STARTTLS. Für Port 25 und 587 (beide absolut identisch) hingegen TLS/STARTTLS aber nicht SSL.

Am Ende ist es völlig egal WELCHEN Port man nimmt. Es kommt immer SSL/TLS und SMTP zum Einsatz. Es wird historisch bedingt nur völlig durcheinander verwendet und vor allem bezeichnet.


Wir geben verschiedene Ports an, auch weil Mailrpogramme im Laufe der letzten 15 Jahre das unterschiedlich implementiert haben. Ein Uralt-Outlook kennt beispielsweise keinen Port 587 und wenn man dort SSL angibt, will es kramphaft Port 465 benutzen und/oder weigert sich, TLS auf Port 25 zu verwenden. Moderne Programme hingegen denken bei TLS sofort an die 25, ganz moderne denken sowieso an 587.


Es gibt keine "eine" Anleitung die alle Gepflogenheiten aus > 15 Jahren abdeckt. Jedes Programm macht, was es will.


"State of the Art" heute ist aus verschiedenen Gründen TLS auf 587.


Aber: Am Ende wirklich total egal.

Foto
1

/Eigentlich/ sollten alle modernen Mailprogramme eh alle Einstellungen automatisch erkennen. Mailadresse + Passwort eingeben, nix separat rumpfriemeln: speichern und loslegen.

Foto
1

Wow, das war schnell ;-)


Den Autodetect-Button in KMail hatte ich bisher tatsächlich gar nicht bemerkt.


Vermutlich wäre es sinnvoll, auf der Doku-Seite zur manuellen Einrichtung

(https://support.mailbox.org/knowledge-base/article/einrichtung-mit-sonstigen-mailprogrammen)

dann die heute gültigen/sinnvollen Werte für manuelle Einrichtung anzugeben, die dann offenbar wären:

Port 465 + SSL

Port 587 + TLS

(alternativ: Port 25 + TLS)


Danke & schöne Grüße

Foto
1

Hi! ich habe eine sehr ähnliche Frage mit einem konkreten Problem, hoffentlich kann da jemand vom Support da helfen, da sie alle UNIX/Linux experte sind :) . Was wäre der Konkrete Syntax für das smtp_url für Mutt? ich kriege es nicht auf die Reihe! offensichtlich hat es genau mit dieser Port vs. SSL/TLS Sache zu tun!


Vielen Dank!

Foto
1

Ich habe es nicht getestet, aber

set smtp_url = "smtps://user@smtp.mailbox.org:465/"

sollte gehen

Foto
1

Danke! das ist genau was ich habe. Ich befürchte, der Fehler liegt trotzdem an die konfiguration der anderen Zeilen; ich habe diese drei Optionen:


set ssl_starttls="yes"

set ssl_force_tls="yes"

set ssl_use_sslv3="yes"


Welche(n) soll ich "uncomment"?


Vielen Dank für die Zeit und Mühe!

Foto
1

Wieso probierst du es nicht einfach mit den defaults? ssl_use_sslv3 (default: no) gehört aber auf alle Fälle raus. Welchen Fehler bekommst du?

Foto
1

Also wenn ich die ersten zwei unkommentiere und die dritte komplett raus ist, bekomme ich " 501 Syntax: EHLO Hostnamen"

Foto
1

Funktioniert es wenn du einen FQDN als hostname in der muttrc setzt?

Foto
1

Was meinst du denn mit "einen" FQDN? Beispiel ? Ich habe geglaubt ich muss nur die Infos von Mailbox.org angeben ?

Foto
1

Was wird denn angezeigt wenn du in mutt ":set ?hostname" eintippst?

Probier mal "mypc.example.net" oder so. Ich kann das Problem leider nicht nachvollziehen.

Foto
1

Ja ich kann es auch nicht nachvollziehen, deswegen die lästige Forum-Posts :). Also jetzt kenne ich mir nicht mehr aus; diese Sache mit dem FQDN, ich verstehe das Konzept, aber ich verstehe nicht en warum es für Mutt relevant ist und inwiefern das mit dem eigenen Rechner zu tun hat ? Konkret: wo soll ich "set Domain: mypc.example.com" ? In mutt selbst ? Oder in muttrc? Oder anderem Config file ?? Herzlichen Dank für deine Hilfe !!

Foto
1

Kannst du mutt starten und ":set ?hostname" eintippen? Was wird angezeigt? Dieser Wert wird im EHLO gesendet und offenbar passt da etwas nicht.

Die Variable "domain" gibt es nicht. Zum Testen würde ich den Befehl set in mutt direkt aufrufen. Wenn du es in .muttrc änderst, musst du halt mutt immer neustarten. Mit "?set" kannst du den Wert abfragen.

Foto
1

OK, der Fehler kommt z.B. wenn man nur ein Leerzeichen im hostname hat. Hast du set hostname=" " in deiner .muttrc? Sonst wird eigentlich (fast) jeder Mist akzeptiert.

Foto
1

Eigentlich habe ich gar nichts in meinem .muttrc was dem Hostname betrifft. Soll ich?? Die Abfrage direkt im Mutt hat einfach den Output hostname="" ergeben.

Foto
1

Setzt halt mal hostname (z.B.: localhost oder mypc). Was ist das für ein BS? Und welche mutt Version?

Foto
1

Mutt Version: 1.8.2,. Betriebssystem DragonFly BSD, von der Konfiguration her identisch mit FreeBSD. Ich habe mittels .muttrc einen Hostname gesetzt, jetzt kriege ich zumindest nicht mehr *dieselbe* Fehlermeldung. Dieses Mal wurde ich zum ersten Mal, seitdem ich das versuche, nach meinem Passwort gefragt. Daraufhin: SASL authentication failed!

Foto
1

Verwendest du als user die E-mail Adresse? Also:

set smtp_url = "smtps://user@mailbox.org@smtp.mailbox.org:465/"

Foto
1

AHA! That did the trick. hatte nämlich den ersten @mailbox.org nicht. Boah Mann, mögest du lebenslang mit dem besten Gebäck versorgt werden! danke!!!

Foto
Foto
1

Hi. Um das Thema wieder aufzufrischen. Das mit den Ports ist immer noch merkwürdig.


Siehe hier: https://kb.mailbox.org/pages/diffpagesbyversion.action?pageId=1180573&selectedPageVersions=2&selectedPageVersions=1


Warum jetzt mit iOS 12.4 den Port 587 sonst 465.


Kann man es nicht einheitlich lassen??

Foto
1

"Bei SMTP gibt es häufig etwas Verwirrung darüber, welche Ports zu verwenden sind. Da Mail-Programme hier häufig irgendwie herumraten und dabei oft falsch liegen (ja, je benutzerfreundlicher die Programme daherkommen, desto schlimmer wird es hier leider), hier eine bildliche Erklärung:

Wenn jemand das Wort Briefkasten verwendet, dann können damit je nach Kontext zwei grundverschiedene Dinge gemeint sein. Genauso ist es per SMTP (leider) auch. Mit „Ich werf' das schnell in den Briefkasten“ ist der große, gelbe Briefkasten an der nächsten Ecke gemeint, hier geht es also um das Abliefern von Briefen bei der Post, damit sie die weitere Zustellung übernimmt. Mit „das hab ich in Deinen Briefkasten eingeworfen“ ist hingegen der kleine Briefkasten in beliebiger Farbe an Deinem Gartentor / Deiner Haustür / in Deinem Hausaufgang gemeint, es geht also um die Anlieferung von Post bei dir.

Bei SMTP hat der Gelbe Briefkasten nur einen Einwurf: TCP Port 587. Wenn dein Mail-Programm etwas anderes „errät“ dann irrt es sich. E-Mails die du Losschicken möchtest, gehen an TCP Port 587 und dort solltest und musst du TLS-Verschlüsselung verwenden, um dein Passwort zu schützen.Dein Programm sollte die Methode der Passwort-Abfrage eigentlich selbständig ermitteln, falls das nicht klappt: Da die Verbindung ja per TLS verschlüsselt wird, kann das Passwort gefahrlos im Klartext übermittelt werden. Diese Methode (die manche Programme in gebrochenem Deutsch auch „Passwort, normal“ nennen) ist die älteste Methode und wird eigentlich von jedem Mail-Programm unterstützt. Ohne Verschlüsselung wäre diese Methode hochgradig unsicher, aber wir bieten ja verschlüsselten Zugriff auf diesen Port an, von daher betrifft uns dieses Problem nicht. (Im Gegensatz zu POP3/IMAP unterstützt das SMTP-Frontend leider nicht die Option, SMTP AUTH über eine unverschlüsselte Verbindung zu unterbinden. Das wäre aber so oder so nur eine Teil-Lösung, denn wenn der SMTP-Server erstmal „Ich nehme deine Authentifizierungsdaten nicht an, weil die Verbindung nicht verschlüsselt ist“ sagt, ist es ja schon zu spät, weil die Daten dann bereits unverschlüsselt übermittelt worden sind, auch wenn der SMTP-Server sie dann nicht akzeptieren würde.)

Die anderen Ports sind nun eigentlich nicht mehr der Rede wert, weil du damit normalerweise nichts zu tun bekommst, aber der Vollständigkeit halber sei hier noch etwas dazu gesagt:

Der Hausbriefkasten hat bei SMTP zwei Einwürfe, einmal auf TCP-Port 25 und einmal auf TCP-Port 465, wobei bei ersterem keine Verschlüsselung vorgesehen ist, bei letzterem TLS-Verschlüsselung verlangt wird. Das ist soweit es um Passwörter geht nicht weiter schlimm, denn für die Anlieferung von Mails wird keine Authentifizierung benötigt. Nur bei der Ablieferung wird das verlangt da wir natürlich nur für unsere eigenen User Mails transportieren." - https://wiki.uberspace.de/mail#smtp

Die Erklärung von uberspace ist ganz gut um zu verstehen, warum Port 587 verwendet werden sollte. Die anderen beiden (25 und 465) werden bei mailbox.org auch zugelassen (wie Peer Heinlein eingangs erwähnte), weil die Mailprogramme in der Vergangenheit (und heute) sich kaum an die RFC halten und kurzerhand mies programmiert sind.

Foto
1

Also kurz gesagt: Port 587 ist immer die bessere Wahl?

Foto
1

Derzeit würde ich sagen: ja.

Das kann sich natürlich zukünftig ändern, wenn die IANA den Ports andere Dienste/Funktionen zuweist (wie sie es mit 465 bspw. gemacht hat). Derzeit ist der Port 465 nämlich nicht für SMTP over SSL standardisiert, sondern: auf TCP-Ebene für URD (URL Rendezvous Directory for SSM) und auf UDP-Ebene für IGMP v3lite (IGMP over UDP for SSM).

Hier gibts kurze Erklärungen zur Historie der Mailports:

Foto
Foto
1

Ich habe schon vor einiger Zeit, also noch vor iOS 12.4, die praktische Erfahrung gemacht, dass mit Port 465 keine Verbindung zustande kam, mit 587 schon. Bei anderen Systemen funktioniert bei mir 465. Also habe ich in meinem Bekanntenkreis die Empfehlung ausgegeben, unter iOS 587, sonst 465. Ich fühle mich quasi nachträglich bestätigt. ;-)