Willkommen im User-Forum von mailbox.org
 

Emailadresse bei eigener Domain (Netcup)

1536784 hat dies geteilt, 21 Monaten her
unbeantwortet

Liebes Userforum,

ich habe bei Netcup eine Domain registriert. Bisher habe ich über den Webnode-Webseitenbaukasten meine Emailadresse gehabt. Mit Webnode bin ich jedoch unzufrieden, der Dienst läuft auch bald ab, deswegen hier die Frage wie ich meine bisherige Mailadresse mail@example.net unter Mailbox weiter nutzen kann?

  • Ich habe unter "E-Mail-Aliasse" meine Externe Adresse hinzugefügt. Wie erwartet ist die validierung der Domain fehlgeschlagen, da ich den Sicherheitsschlüssel (Hostname und TXT-Record) noch nicht bei Netcup eingetragen habe. Im Netcups Controlpanel finde ich den Reiter DNS. Da habe ich meine bisherigen Webnode-Einstellungen auch schon eingetragen. Leider hilft mir die Anleitung nicht weiter. Ist es richtig wenn ich unter HOSTf11ee[...]bcc89.example.net“ unter TYPE "TXT" und unter DESTIANTIONb6963[...]70b38“ eintrage? Siehe Bild:02c7240385fe4e940a814cbea5401dee

Ich möchte natürlich nicht die Domain unbrauchbar machen durch mein Unwissen.


Muss ich sonst noch auf etwas achten? Bisher wird ja meine Adresse mail@example.net woanders genutzt. Kann ich einfach die bisherigen DNS-Zonen-Einstellungen für Webnode-Mail löschen und die Mailbox MX-Records eintragen und erwarten, dass es funktioniert?

Vielen Dank für die Hilfe!

-Linus

Beste Antwort
Foto

Das Bild von Daniel oben veranschaulicht sehr gut, wie die Einträge zu setzen sind, und ist sehr hilfreich.


Für einen "Anfänger" im Bereich DNS/Mail/Domain&Co würde ich allerdings die Empfehlung von Daniel etwas ändern:

1.) Zum Laufen des Postfachs ist ausschließlich folgendes erforderlich:

a) Sicherheitsschlüssel in der Form Host f11ee[...]bcc89 (also ohne example.net) Type Txt Destination b6963[...]70b38

b) die drei mx-Einträge in der Form von Daniels Bild.

Bereits jetzt kann die Mailfunktionalität getestet werden!!! Aber Achtung, bis die Änderung im DNS aktiv wird, dauert es meist ein paar Minuten bis ein paar wenige Stunden.

2.) Etwas "advanced" und ausdrücklich optional wären dann die Einträge MBO00001, MBO00002, _dmarc und spf wie im Bild zu setzen. Bei spf würde ich allerdings im Feld Destination nur v=spf1 include:mailbox.org einfügen. Das übernimmt die Richtlinie von Mailbox.org ohne eigenen Zusatz. Ebenso würde ich bei _dmarc als Destination nur v=DMARC1; p=none; eingeben. Diese Richtlinie verwendet mailbox.org selber und das ist für Privatanwender absolut ausreichend. Der normale nicht technikaffine Privatnutzer hat in der Regel kein Spaß sich durch Reports zu wühlen, oder zu überlegen, warum seine Mails wenn mit DKIM was hakelt, in der Quarantäne landen.

Kommentare (3)

Foto
2

Zuerst einmal, sichere die Domain, wenn der Dienst bald abläuft. Wenn es eine Inklusivdomain ist, dann wird diese mit Ende des Webhosting etc. nämlich gelöscht. Daher ist es wichtig diese Domain in eine eigenständig Domain bei netcup zu übertragen.


Wenn über die Domain nur die E-Mail Dienste laufen sollen, dann werden nur die MX Einträge benötigt. Speziell bei netcup sollte es dann wie folgt aussehen:

AliaseIDTXTPostfach ID

@MX10mxext1.mailbox.org

@MX10mxext2.mailbox.org

@MX20mxext3.mailbox.org

MBO0001._domainkey TXT v=DKIM1; k=rsa; p=MIIBIjANBgkq [...]

MBO0002._domainkey TXT v=DKIM1; k=rsa; p=MIIBIjANBgkq [...]

@TXTv=spf1 include:mailbox.org ?all

_dmarcTXTv=DMARC1; p=quarantine; sp=quarantine; rua=mailto:abuse@domain.de; ruf=mailto:abuse@domain.de; adkim=r; aspf=r; rf=afrf; pct=100; ri=86400


Für den genaue DKIM Eintrag siehe >> https://kb.mailbox.org/plugins/servlet/mobile?contentId=1179862#content/view/1179862


Mehr ist nicht notwendig und es kann damit auch nicht kaputt gemacht werden.

ea33647b55f25607d307ed41df86c7c7

Foto
1

Ich glaube, dass ‘?all' sollte man hinten am SPF Eintrag weglassen. Das wird von mailbox.org dann automatisch gesetzt (und ist aktuell sogar ein '~all')

Aufgelöst sieht es dann so aus:

v=spf1 ip4:213.203.238.0/25 ip4:195.10.208.0/24 ip4:91.198.250.0/24 ip4:80.241.60.0/24 ip6:2001:67c:2050:104::/64 mx ~all

Foto
1

Bei einer externen Domain müssen diese Einstellungen gesetzt werden, wobei auch ohne den Zusatz bei sog, aber wenn dann mit ?all >> https://kb.mailbox.org/plugins/servlet/mobile?contentId=1179862#content/view/1179862

Es könnten auch noch die autoconfig Einträge gesetzt werden, wobei die bei mir nie funktionieren.

Foto
3

Das Bild von Daniel oben veranschaulicht sehr gut, wie die Einträge zu setzen sind, und ist sehr hilfreich.


Für einen "Anfänger" im Bereich DNS/Mail/Domain&Co würde ich allerdings die Empfehlung von Daniel etwas ändern:

1.) Zum Laufen des Postfachs ist ausschließlich folgendes erforderlich:

a) Sicherheitsschlüssel in der Form Host f11ee[...]bcc89 (also ohne example.net) Type Txt Destination b6963[...]70b38

b) die drei mx-Einträge in der Form von Daniels Bild.

Bereits jetzt kann die Mailfunktionalität getestet werden!!! Aber Achtung, bis die Änderung im DNS aktiv wird, dauert es meist ein paar Minuten bis ein paar wenige Stunden.

2.) Etwas "advanced" und ausdrücklich optional wären dann die Einträge MBO00001, MBO00002, _dmarc und spf wie im Bild zu setzen. Bei spf würde ich allerdings im Feld Destination nur v=spf1 include:mailbox.org einfügen. Das übernimmt die Richtlinie von Mailbox.org ohne eigenen Zusatz. Ebenso würde ich bei _dmarc als Destination nur v=DMARC1; p=none; eingeben. Diese Richtlinie verwendet mailbox.org selber und das ist für Privatanwender absolut ausreichend. Der normale nicht technikaffine Privatnutzer hat in der Regel kein Spaß sich durch Reports zu wühlen, oder zu überlegen, warum seine Mails wenn mit DKIM was hakelt, in der Quarantäne landen.

Foto
1

@#Daniel Du hast recht mit der Verlinkung in die KB - aber ich glaube die ist in dem Bereich nicht aktuell (wurde nicht geupdated). Mit v=spf1 include:mailbox.org fährst Du auf jeden Fall am Besten. (Da übernimmt mailbox.org die Arbeit für Dich).

Foto
1

@Den: die ist aktuell, den dort stehen schon die aktuellen DKIM Schlüssel drinnen und dort wird ja auch auf v=spf1 include:mailbox.org ohne -all und maximal ?all hingewiesen.

Foto
1

@#Daniel: Die haben den Part übersehen!

Geh mal dmarcanalyzer.com und gebe mal mailbox.org ein - dann siehst Du die Resultate. Steht auch hier im Forum das geändert wurde. Es ist definitiv ~all aktuell

Foto
1

Es bestreitet doch keiner das ~all aktuell ist, was allerdings durch das include:mailbox.org schon übernommen wird und das steht auch im Artikel. Man nimmt nur nicht mehr -all, gut und ?all auch nicht unbedingt, ist aber auch nicht falsch, am besten beides weglassen.

Mein Eintrag:

2cc6c0e4b95bb4c6095cf04858c6f47f

Foto
1

Genau das habe ich ja oben geschrieben ;-)

Foto
1

Hallo zusammen,

hänge hier derzeit auch fest.


Habe hier ganzen unten "netcup nameserver" ausgewählt statt einen eigenen. Warum? ich wusste nicht welche IP ich als Destination angeben soll.


Könnt Ihr Euch mal meinen Screenshot anchauen? Die roten Kreise habe ich eingefügt. Passt das?

Habe den Provider gewechselt, lief also vorher uch schon mit .de Domain und Mailbox, allerdings stecke ich jetzt hier bei netcup etwas fest.


v=DMARC1 und v=DKIM1 würde ich auch noch anpassen.

Bisher klappt bekomme ich noch "Fehler: Validierung der externen Domain fehlgeschlagen" angezeigt. Evtl sind die Server noch nicht umgestellt, mir geht es grundsätzlich um meine Settings. Den Hostnamen habe ich ohne .domain.de eingetragen.


Danke!

7f30283f109b51cf0d4b8f9f6d49cd11

Foto
2

Sieht alles korrekt aus.

Foto
2

Bei den MX Einträgen bitte auf jeden Punkt etc. achten, sonst wird das nix. Diese Einträge enden nicht auf .mailbox.org. sondern auf .mailbox.org , das ist sehr wichtig. Bei netcup.de dauert die Aktualisierung der DNS Einträge immer ein wenig und dann müssen diese Einträge natürlich auch von anderen DNS Servern repliziert werden. Hier kann es je nach Provider (spricht Telekom etc) auch mal durchaus 48h dauern, in der Regel aber über Nacht (eigene Erfahrung).

4fe4dbdfa694ddd7825522078f5dd57e

Foto
1

Also ich weiß nicht genau, was Netcup da macht.

Nach DNS-Standard MÜSSEN die Einträge (korrekt) wie im Screenshot gezeigt, auf einen "." enden. Es /kann/ natürlich sein, daß Netcup da irgendwas jenseits der guten Gepflogenheiten und 30jährigen Best Practice macht. Vielleicht auch absichtlich, weil ihre User das sonst nicht verstehen. TECHNISCH jedoch wäre der Punkt absolut korrekt, denn nur der verhindert eigentlich, daß der DNS-Server sonst die ursprüngliche Domain anhängt.

Also ohne Punkt würde daraus ein

@ MX 10 mx1ext.mailbox.org.domaindeskunden.de

werden, mit Punkt schließt er den Eintrag ab und es bleibt bei


@ MX 10 mx1ext.mailbox.org.


Aber kann auch sein, daß Netcup das halt anders macht. Jeder kann manchen, was er will und wer's partout haben will, könnte auch ein X nehmen oder so. Sinnfrei, aber möglich...


EIGENTLICH ist DNS total einfach, aber leider sind viele Anbieter der Meinugn das alles in ihren Webinterfaces sonst irgendwie und auch (absichtlich?) falsch dazustellen, so dass alle verwirrt sind. Ich hasse sowas, denn das erzeugt überhaupt erst die Verwirrung weswegen User DANN sagen, es wäre so kompliziert.

Eigentlich ist es einfach: Ist der Hosteintrag bereits abgeschlossen, muß er auf einen "." enden. Fehlt der Punkt, hängt der DNS-Server die Domain der jeweiligen Zone erst noch an.

Foto
1

Danke @ #Daniel und Herr Heinlein.


Du meinst "v=spf1 include:mailbox.org" sollte "v=spf1 include:mailbox.org." sein? Zumindest habe ich hier bei der Anleitung keinen Punkt entdeckt.


Gibt es keine Probleme mit 2x spf1 Einträgen? 1x mailbox und 1x spf.webhosting?

Bin nur etwas verwundert, ob ich die ganzen Einträge von netcup (IP-Adressen, autoconfig) einfach so stehen lassen soll/kann.


Habe bisher mit CatchAll und dieser Domain gearbeitet, wollte jetzt auf Alias-Adressen (pro Login/Account) umsteigen, um in Fall der Fälle eine jeweilige Alias-Adresse einfach löschen zu können.

Für CatchAll würde ich eine eigene Adresse nutzen, falls jetzt bei der ganzen Umstellung nicht doch noch eine Mail bei mir ankommt.


//Edit: Habe eure Antworten gesehen. ich war vorher bei gandi.net, dort musste ich ein "." an das Ende setzen.

Foto
1

Nein, ich meinte bei den MX Einträgen (siehe Screenshot). Die SPF Einträge würde ich zusammenfassen, ist ja kein Problem (auch wenn der Eintrag nur bedingt hilfreich ist). Zudem würde ich noch den DKIM Eintrag setzen, der bringt, find ich, mehr als SPF, wenn auch nur bedingt.

@Peer: Gerade gemerkt, dass es ein Reizthema ist ;-) (Zitat: "Ich hasse sowas, denn das erzeugt überhaupt erst die Verwirrung weswegen User DANN sagen, es wäre so kompliziert."). Ich möchte gar nicht ausschließen das es auch mit dem Punkt am Ende funktioniert, nur wenn ich den DomainKey setze muss schreibe ich hier (bei Netcup) auch nicht _domainkey.domain.de sondern nur _domainkey und das Webinterface vervollständig das mit der entsprechenden Domain im Hintergrund.

Foto
1

Alles klar, Einträge wurden wohl geschluckt. Allerdings kamen ein paar Testmails wieder zurück, hier greifen die Settings wohl noch nicht global.


mxext1.mailbox.org[80.241.60.212] said: 550 5.1.1

<test@domain.de>: Recipient address rejected: User unknown in relay

recipient table (in reply to RCPT TO command)


Foto: 477923bfe9c782febaba0a035dee0e46

Foto
2

Ist den der entsprechende Alias im Mailbox.org Account schon hinterlegt (denke mal @domain.de ist hier nur als Dummy für die korrekte Domain)?

Foto
1

Alles klar, lag wohl daran, Mails an die Domain kommen jetzt in meiner mailbox an.


Wenn ich innerhalb von mailbox nun einen Alias "@domain.de" anlege, kommt dann quasi ALLES@domain.de auch an, korrekt? domain.de = dummy, korrekt.

Kann ich z.B. auch BLABLA@domain.de anlegen, und dann bei NetCup Weiterleitungen auf diese Mail schalten?


Wie gesagt, ich würde gerne etwas weg von CatchAll kommen und mit Alias-Mails arbeiten um im Fall der Fälle eine Alias zu löschen.


onlineshoppingebay@domain.de soll bei Leak eben "schnell" löschbar sein, statt jede Mail über ALLES@domain.de zu erhalten. Hoffe ich erkläre es verständlich ;)


PS: 2056a14a6b12e355926f384503025ffb

Foto
1

Alles klar, CatchAll funktioniert.

Sehe ich das richtig? Durch Umstellung der kompletten MX-Records zu mailbox.org, kommen jetzt entweder ALLE Mails an *@domain.de (Alias eingetragen) zu mailbox.org, oder eben an zwei weitere Alias-Mails shopping@domain.de und foren@domain.de


Wenn ich innerhalb von netcup.de der Adresse "shopping@domain.de" eine Alias-Adresse verpassen, zB shoppingAMAZON@domain.de, kommt diese nicht an weil nicht existent, sofern ich *@domain.de aus den Alias-Adressen bei mailbox.org lösche


Ich glaube meine Vorstellung von "jeder Anbieter eine eigen Adresse", welche ich bei Leak einfach löschen/sperren kann vs. CatchAll für ALLES klappt aktuell nicht so wie ich mir das im Kopf vorstelle. Oder ich setze einfach die falschen Settings ;)


//edit: Okay, es geht wohl auch darum.

Foto
2

Wenn im DNS bei Netcup die MX Records mit @ gesetzt werden, dann werden alle Mails an Mailbox.org als Empfänger geleitet, ganz egal was vor @domain.de steht. Bei Mailbox.org kommt es darauf an, ob die Domain mittels einzelner Aliase, z.B. info@domain.de oder als Wildcard Domain eingebunden wurde. Im letzteren Falle werden alle E-Mails von Mailbox.org an das Postfach zugestellt (unter der Voraussetzung der @ Konfiguration bei netcup).

Soll jeder Anbieter ein eigenes Alias bekommen, muss dies in Mailbox.org unter Einstellungen so definiert werden, dann werden andere Mail (keine Wildcard Konfiguration) abgelehnt (Fehler 550).

Foto
1

Korrekt, so habe ich es eingestellt. Aktuell kommt jede Mail über *domain.de bei mailbox.org an.

Da ich wohl mit meinen Accounts auf über 100 komme, bräuchte ich also auch 100 Alias-Mails. Scheint, wie ich hier jetzt im Forum schon gelesen habe, nicht zu klappen.


Überleg ob ich jetzt weiterhin mit *domain.de und CatchAll laufen lassen, aber dafür Filterregeln einsetze.


1. Verwerfen -> An -> *@domain.de

2. Behalten -> An -> amazonshopping@domain.de

3. Behalten -> An -> sparkassebanking@domain.de

4. Behalten -> An -> spotifyeaccount@domain.de

Werde dann wohl die ganzen Logins auf den Seiten umstellen müssen und darauf hoffen, dass mir nichts urch die Finger rutscht. Für Ideen/Tipps bin ich natürlich offen :)

Foto
1

Wenn die erste Regel zutrifft, dann werden weitere E-Mails sehr wahrscheinlich nicht mehr zugestellt. So aufwendig würde ich das nicht machen und bei sehr unsicheren Kandidaten kann man ja Einmaladressen verwenden. Ich glaube wichtiger ist es für jede Website ein eigenes Passwort zu haben.

Der SPAM Filter bei Mailbox.org funktioniert, bis auf wenige Ausnahmen, eigentlich ganz gut, sodass diese eventuelle Verwendung der Mail als SPAM Empfängeradresse sehr schnell scheitert. Ich war auch bereits bei zwei Leaks mit einer E-Mailadresse betroffen und SPAM Aufkommen ist fast keines zu verzeichnen.

Foto
1

Bisher habe ich meine Mails pro Account tatsächlich so erstellt:


cBzBhUA4dMXqD3Yx@domain.de, also 16 Zahlen/Buchstaben. Innerhalb von KeePass dann abgespeichert und dann auch direkt gesehen, welche KRYPTOMAIL@domain.de zu welchem Account gehört. Habe schon oft von solchen Beispielen wie amazonshopping@domain.de gelesen. "Krypto" wäre für den Filter eine Qual, mit "amazonshopping" noch halbwegs machbar.


Alles klar, dann lasse ich es einfach mal so laufen und hoffe auf den Filter. *fingerkreuz*

Foto
1

Dieser kann auch noch schärfer eingestellt werden oder eingehende Mails als SPAM angelernt werden. Zusätzlich können auch Domains komplett auf die Liste der abzulehnenden Absender gesetzt werden.

Foto
1

Hallo,

ich habe zu netcup gewechselt und bin seit 2 Tage ohne E-Mail. Ich habe die Konfiguration wie @einuser geschrieben hat. Also, Punk 1. a) und b). https://userforum.mailbox.org/topic/emailadresse-bei-eigener-domain-netcup#comment-18228

Bräuchte ich eigentlich noch etwas? Die Authentifizierung ist geklappt aber die MX (ohne Punkt) scheinen nicht zu funktionieren. Ich habe die A-Records mit IPs von netcup gelöscht. Sollte ich nicht?

Foto
1

Für den reibungslosen Betrieb benötigst Du nur die einmalig Authentifizierung mittels TXT Eintrag (könnte danach streng genommen wieder gelöscht werden) und die drei MX Einträge. Sind diese richtig gesetzt? Bei Netcup funktioniert das auch ohne Punkt am Ende der Domain, aber streng genommen gehört dieser dazu (auch das funktioniert).

Geht der E-Mail Empfang den jetzt?

Foto
1

Wie ist das eigentlich?

Domain bei mailbox.org registriert:

  • TXT Eintrag gesetzt
  • danach läuft alles wie gewollt
  • aber dann wird der Mailanbieter z.B. gewechselt (also weg mit der Domain zu einem anderen Anbieter)
  • DNS folglich auf den neuen Anbieter angepasst

Wie wird dann das alles wieder rückgängig gemacht? Also sprich, dass man mit dieser Domain nicht mehr über mailbox.org versenden kann.

Wird das irgendwo geprüft, oder ist das für immer so?

Foto
1

Hallo,

danke für die Antwort. Ja, geht. Ich kann senden aber bekomme nicht alles. Ein paar E-Mails von Kollegen sind verloren gegangen. Vielleicht ist um diese Uhrzeit alles ok.

Ich würde sagen, dass ich keinen Fehler gemacht habe, sondern bei netcup extrem lange gedauert hat und ich fast verrückt geworden bin. ;)


Ah! Ich konnte vorher E-Mails zu mir selbst schicken. Von mymail@mailbox.org zu mymail@mydomain.com Aber jetzt nicht. Woran kann das liegen? Oder einfach weiter warten?

Foto
1

@Den: wenn die Domain einmal freigeschalten ist, dann kann mit dieser eigentlich die ganze Zeit von Mailbox.org von dieser etwas versandt werden (ist noch nicht optimal gelöst). Hier sollten aber der empfangende MailServer eingreifen und die Mail ablehnen (Stichwort Reverse PRT). Dieser müsste prüfen ob der sendende MailServer bzw. die IP passt.

Der neue MailServer wird natürlich durch den neuen MX Eintrag zum Empfang berechtigt und gleichzeitig ist aber kein Verweis mehr auf Mailbox.org. Sprich bei neuen Anbieter kannste weiterhin von Mailbox.org senden aber keine Mail mehr empfangen.

@NJ: Wenn der E-Mail Empfang jetzt passt dann ist DNS wohl richtig gesetzt. DNS Änderungen brauchen bis zu 48h bis die überall bekannt sind, in aller Regel aber nach 24h. Daher kann es auch ruhig dauern und so lange sollte man die Domain zum Empfangen nur begrenzt nutzen. MailServer versuchen aber in aller Regel eine neue Zustellung wenn die E-Mail nicht zugestellt werden kann, aber nur wenn der Empfangende einen temporären Fehler sendet. Sagt dieser ob ich kenn das Postfach nicht, aber hier sollten die Mail entweder beim alten Anbieter angekommen sein (wenn DNS noch nicht vollständig repliziert war) oder aber dann bei Mailbox.org. Daher löscht man ein altes Postfach nicht sofort, sondern erst nach mehreren Tagen.

Wenn Du eine Mail vom Postfach @mailbox.org an eine Alias im selber Postfach (@mydomain.com) dann sollte dies eigentlich sofort erfolgen. Bei einem Fehler bekommst du eigentlich eine Fehlermeldung.

Foto
1

-- Wenn Du eine Mail vom Postfach @mailbox.org an eine Alias im selber Postfach (@mydomain.com) dann sollte dies eigentlich sofort erfolgen. Bei einem Fehler bekommst du eigentlich eine Fehlermeldung.


Nein. Gerade geht nicht. Weder von Mail-Client noch von Webmail. Auch keine Fehlermeldung.

Foto
1

ich habe aktuell genau dasselbe Problem. Emails aus meinem Postfach an meine Domain (z.B. an meinen Alias name@domain.de) verschwinden einfach im Nirvana. Sende ich eine Email an oder von einem externen Anbieter, klappt alles. Hast Du das Problem lösen können?

Foto
2

Ja bzw. der Support hat mein Problem gelöst. Etwas im Mailbox-System war nicht sauber und hat einen "Check" verpasst.

Das beste war, dass ich keine E-Mail verloren hatte. Alles war bei Mailbox und bekam alles zusammen.


Also nimmt Kontakt mit dem Support. Viel Glück.

Foto
Foto
1

Fehlermeldung kommt nur bei einem Abbruch, andernfalls wir in der Regel weiterhin versucht zuzustellen. Klappt es den auch komplett von einem externen Postfach?

Foto
1

@Daniel Ja.