Willkommen im User-Forum von mailbox.org
 

Falsche URL in Kalender-Einladungen

pk hat dies geteilt, 3 Jahren her
in Arbeit

Wenn eine Kollegin / ein Kollege im Webinterface einen neuen Termin

einträgt, und ich eine automatische Benachrichtigung bekomme, hängt

diesen immer ein Link in der Form

https://office.mailbox.org/#m=calendar&i=XXXX&f=YYY

an. Dieser Link leitet jedoch nur auf die Willkommens-Seite von mailbox.org um.

Richtig wäre

https://office.mailbox.org/appsuite/#m=calendar&i=XXXX&f=YYY

Es wäre schön, wenn Sie dies zeitnah korrigieren könnten.

Herzliche Grüße !

Kommentare (12)

Foto
1

Ich habe das eben mal nachgestellt.

Der Link in der E-Mail funktioniert nur bei Aufruf in unserem Webmailer und öffnet dort in der Suite ein Übersichtsframe zum Termin.

In einem externen E-Mailclient klappt das nicht, würde aber auch nur mit dem korregierten Link funktionieren, wenn Sie mit Ihrem Account bereits im Webmailer eingeloggt sind.

Foto
1

Ja, das bin ich normalerweise. Falls nicht, ist der Redirect auf die Login-Seite ja völlig nachzuvollziehen, und dann klickt man nach dem Login halt den Link nochmal. Aber wir werden auch weiterhin unsere Emails mit einem lokalen Mail-Client lesen. (Das hier dann die Einladungen ohne .ICS Anhang ankommen, ist ein separates Problem.)


Der Link mit /appsuite/ würde ja funktionieren. Ihr System müsste ihn nur schicken.

Foto
1

In dem Fall öffnet sich das Frame im Webmailer aber nicht.

Foto
1

Das haben Sie korrekt beobachtet. Wie ich bereits schrieb, tut das meinem Use Case aber keinen Abbruch.


Werden Sie diesen Fehler in Ihrer Software jetzt an Ihr Technik Team eskalieren (möglichst zusammen mit der von mir vorgeschlagenen, trivialen URL-Änderung) , oder möchten Sie ihn gerne noch eine Weile lang wegdiskutieren ?


Mit freundlichen Grüßen

pk

Foto
1

Ich gebe das natürlich gerne weiter, bitte Sie aber Anfragen an den Support direkt an diesen zu stellen support@mailbox.org.


Auch prüfen wir in diesem Fall ob dies ein Bug, ein mögliches Feature oder so nicht gewollt ist.

Foto
1

Addendum an den Support-Mitarbeiter:

Sie treten als " mailbox.org Support" auf, aber schreiben mir

> bitte Sie aber Anfragen an den Support direkt an diesen zu stellen support@mailbox.org.


Also entweder gehören Sie zum Support-Team oder nicht. Der Sinn dieser Seite scheint mir doch gerade zu sein, dass Sie Kunden-Support in öffentlich sichtbarer Art und Weise leisten, um andere Kunden darauf verweisen zu können bzw. Wiederholungsanfragen sogar vorzubeugen. Sollten Sie hier keinen Support leisten wollen, bitte ich Sie, dies nach aussen konsistenter zu kommunizieren.


Mit freundlichen Grüssen

pk

Foto
1

@pk: auf der Startseite des Forums ist die Zielstellung klar beschrieben: Im Userforum helfen sich mailbox.org-User gegenseitig.


Ergo: wenn man Hilfe durch den techn. Support von mailbox.org haben möchte, dann soll man sich an den Support wenden, wurde und wird hier immer wieder darauf hingewiesen. Wenn der Support ein Problem nicht lösen kann, dann wird es an die Entwickler als Bug weitergegeben und dann kann es etwas länger dauern, bis es gelöst werden kann, wurde hier auch schon mehrfach erläutert.


@Support: vielleicht könnte man das auf der Startseite deutlicher hervorheben, in Fettschrift oder so, damit die Fragesteller das auch mal wahrnehmen. Es gibt hier immer wieder die gleichen Diskussionen, die irgendwie nerven.


Technisch kann ich das Problem nicht nachvollziehen, wenn ich eine Einladung zu einem Termin von einem anderen Mailbox Kunden kriegen, dann ist eine ICS Card ganz ohne Links. Ich klicke auf "Übernehmen" und der Termin steht in meinen Kalender. Scheint also ein ziemlich spezielles Problem zu sein.

Foto
1

Das Problem betrifft nur Business-Kunden von mailbox.org, die innerhalb einer Firma einzelne Kalender zur Bearbeitung durch andere Mitarbeiter freigegeben haben. (Das kommt bei der Frage oben nicht klar zum Ausdruck.)


Normale mailbox.org Endkunden sind von diesem Problem nicht betroffen. Sie erhalten eine Einladung via ISC, die sie in ihren Kalender übernehmen können. Dabei ist es egal, ob Sie das Web-GUI von mailbox.org nutzen oder einen lokalen Client wie Thunderbird o.ä.

Foto
Foto
1

Eine "triviale Änderung" sorgt am Ende für drei involvierte Kollegen, einen Rollout im Test-Cluster, eine Testreihe, einen Config-Change um Mitternacht und alles in allem schnell 10 Stunden Arbeit.


Ich bitte um Verständnis, daß es für alle Beteiligten SEHR viel Sinn ergibt zuerst die Anforderungen, Vor- und Nachteile zu klären BEVOR eine derartige Aufwandskette losgetreten wird.


Auch für die Admins im 2nd level ist wichtig zu wissen, was wodurch bezweckt und bewirkt wird um abzuschätzen, ob das tatsächlich der Grund ist, ob etwas anderes im Wege steht oder oder oder.


Nach dem derzeitigen Stand der Diskussion wird es zu diesem Change auch noch kein OK geben; das müssen wir zunächst prüfen. In der Authentifizierungen hängen auch OneTimePasswords, hängen im Hintergrund Sessions zu unseren Verwaltungsinterfaces und und und. Es kann sein, daß ein einfacher direkter Login im OX nicht geht und hinten raus bei tausenden von Usern alles kaputt machen würde.


Eine unbedachte Änderung hier kann zum Chaos führen, auch wenn das für Sie scheinbar trivial aussieht.


Insofern bitte ich um Verständnis, daß der Kollege hier nicht etwas "wegdiskutiert", sondern ganz im Gegenteil hervorragend seinen Job im 1st level macht um alle Dinge zunächst zu klären, damit der Change dann ggf. schnell, sicher und effizient kommt. Erst nachdenken und diskutierten und dann handeln spart hinten eine Menge Zeit. Der Kollege beschleunigt Ihre Anfrage hier in Wirklichkeit, denn was diskutiert und geklärt ist, muß im 2nd level nicht erst noch aufwändig diskutiert werden von Kollegen, die dafür keine Zeit haben.

Foto
1

Hallo Herr Heinlein,

nur um das klar zu stellen: ich habe _nicht_ verlangt, dass aufgrund dieses Links eine automatischer Authentifizierung o.Ä. passiert. Ich habe nur erbeten, das statt des (immer kaputten) Links ein korrigierter (bereits getestet, geht) ausgesendet wird.


Der den Einladungs-Emails versendete Link _war_ evtl. mal korrekt, aber irgend eine Ihrer Komponenten ist seit dem umkonfiguriert worden (und eine andere Komponente nicht entsprechend angepasst worden), so dass man ohne ein /appsuite/ in der URL _immer_ auf der Login-Seite landet. Auch wenn man schon eingeloggt ist.


Auch die Aussage Ihres Support-Mitarbeiters, dass dies kein Problem darstelle, wenn man die Emails auch über das Web-Interface liest, kann ich so nicht bestätigen. Folgendermaßen lässt sich das Problem auch im Web-Interface sehen:

- Eine Einladungs-Email öffnen

- nach unten scrollen bis zu "Direkter Link"

- Rechtsklick auf "Termin", in neuem Tab öffnen

- Der Browser versucht https://office.mailbox.org/#... zu öffnen und wird nach https://mailbox.org/#.. weitergeleitet - wo man sich erneut einloggen muss.


Wie Sie, Ihr Mitarbeiter, Ihr Support-Team noch weitere Rückfragen in der Sache haben, kontaktieren Sie mich gerne per Email.


Mit freundlichen Grüßen,

pk

Foto
1

Wir haben das Problem eingegrenzt und als Bug Report an die Software Entwickler von Open-Xchange weitergeleitet.

Foto
1

Herzlichen Dank !