Willkommen im User-Forum von mailbox.org
 

kein privater Schlüssel vorhanden

4909277 hat dies geteilt, 2 Jahren her
beantwortet

Hallo Mailfans,


ich habe ein Problem, und zwar habe ich mir mein Postfach neu eingerichtet. Ich habe da offensichtlich einen Fehler gemacht. Ich habe versehentlich den privaten Schlüssel gelöscht, weil ich das Passwort nicht ändern konnte. Jetzt zeigt mir das Postfach immer den Fehler an:"kein privater Schlüssel vorhanden" was kann ich tun?

Vielen Dank für die Hilfe

Kommentare (12)

Foto
1

Sie können eine neuen Schlüssel im Guard generieren, dann ist dieser aktiv.

Ider sich schreiben support@mailbox.org mit dem Wunsch zur Löschung Ihres Guard.

Foto
1

Ich habe das schon versucht mit einem neuen Schlüssel, hat leider nicht funktioniert. Auch hat das löschen der Schlüssel und das neu erstellen nichts gebracht. Und der Support von mailbox.org meldet sich leider nicht bei mir.

Foto
1

ich schaue mir das an und gucke in die Tickets nach einer entsprechenden E-Mail

Foto
1

Vielen, vielen Dank. Was E-Mail Verschlüsselung angeht gilt bei mir UZB (user zu blöd) ha ha. Danke

Foto
1

Leider kann ich die Mail von mailbox.org nicht öffnen, da sie verschlüsselt ist. Da gilt auch die Fehlermeldung:"kein privater Schlüssel vorhanden"

Foto
2

Wenn Du noch den alten Public-Key zum nunmehr gelöschten privaten Schlüssel in der Eingangspostfachverschlüsselung hast, so solltest Du den da tauschen oder deaktivieren. Ansonsten werden neue Mails nach wie vor mit dem alten Key verschlüsselt.

Foto
1

Ich habe alles deaktiviert und es funktioniert dennoch nicht. Habe auch den privaten Key deaktiviert und es kommt immer nooch die Fehlermeldung:"für dieses Objekt ist kein privater Key vorhanden. Es wäre am besten wenn das Postfach komplett zurückgesetzt würde.

Foto
1

Wenn Sie mir per Mail antworten, antworten sie am besten auf meine secundäre Mail Adresse. Danke

Foto
Foto
1

Ich vermute jetzt mal:


Du versuchst eine ALTE Mail zu öffnen, die noch mit dem alten (nun gelöschten) Schlüssel verschlüsselt ist. Wenn Du neue Schlüssel erzeugst dann hat der Guard zwar (private) Schlüssel, aber eben nicht DIESEN, der für diese Mail notwendig ist.


Da Guard keinen (passenden) Schlüssel findet, dessen ID zu der alten verschlüsselten Mail passt, zeigt er das entsprechend an. Das ist dann aber auch ein nicht-lösbares Dilämma: Ist der alte Key gelöscht wird es eben nie wieder möglich sein, diese alten Mails zu entschlüsseln. -Das ist ja auch gut und richtig so.


=> Eventuell sollten wir hier mal an die Entwickler weitergeben, daß sprachlich aus "kein privater Schlüssel vorhanden" ein "Kein privater Schlüssel mit der richtigen ID vorhanden" wird oder sowas.

Foto
1

Zitat: Da Guard keinen (passenden) Schlüssel findet, dessen ID zu der alten verschlüsselten Mail ....


Das ist ja das Problem. Auch bei neuen Mail, die ich mir selbst als Test geschickt habe kommt die Meldung mit dem genauen Wortlaut:"Für dieses verschlüsselte Objekt ist kein privater Schlüssel vorhanden. Schlüssel ID........"

Foto
1

Wenn Du Dir die neue Mail verschlüsselt zugeschickt hast, und Du, wie oben beschrieben, "alles deaktiviert" hast, also im Guard keinen passenden privaten Schlüssel mehr hast, kann ja auch nichts entschlüsselt werden => Fehlermeldung!

Oder es ist doch immer noch die Postfachverschlüsselung aktiv, es existiert aber im Guard der passende private Schlüssel nicht mehr.

Im Übrigen macht es nicht viel Sinn, mal mit dem Support per Mail zu verhandeln, und dann wieder hier Meldungen einzustellen. Wer soll denn da noch durchblicken, wie der aktuelle, konkrete Sachstand ist.

Foto
Foto
1

Hallo 4909277,

es wurde weiter oben schon erwähnt, aber wenn Sie unsere und selbst Ihre eigenen zugesendeten E-Mails nur verschlüsselt empfangen, ist offenbar die Funktion "Ihr verschlüsseltes Postfach" noch aktiv.


Darum bitte nochmal unbedingt in die Einstellungen gehen:

E-Mail ==> Ihr verschlüsseltes Postfach

Dort die Option "PGP-Verschlüsselung für eingehende E-Mails aktivieren" abwählen/ausschalten

Darunter auch den Public Key aus dem Formularfeld entfernen.

Einstellungen verlassen.

Sicherheitshalber nochmal in die gleichen Einstellungen und prüfen ob die Änderungen übernommen wurden.

Ein Menü darunter "Filterregeln" darf es die Regel "Ihr verschlüsseltes Postfach" nicht mehr geben oder Sie muß kursiv ausgegraut (also nicht aktiv) sein.

Jetzt bitte nochmal eine E-Mail an sich selbst senden.

Diese darf jetzt im Posteingang nicht mehr verschlüsselt sein.


Wenn das alles geklappt hat bitte nochmal auf das Ticket antworten (Ticketnr. im Betrefff beibehalten) und den Guard deaktivieren lassen. Ich kümmere mich am Mo darum.


https://support.mailbox.org/knowledge-base/article/wie-kann-man-den-mailbox-org-guard-wieder-deaktivieren