Willkommen im User-Forum von mailbox.org
 

Konfiguration von mutt/neomutt mit mailbox.org

1573732 hat dies geteilt, 10 Monaten her
veröffentlicht

Hallo liebe Mitstreiter,

ich versuche seit einiger Zeit, neomutt so zu konfigurieren dass ich auch Mails verschicken kann. Der Empfang / Sync über IMAP funktioniert einwandfrei,


Hier erstmal meine .neomuttrc:

set from="xxxxx@mailbox.org"
set hostname="imap.mailbox.org"
set spoolfile="imaps://imap.mailbox.org/INBOX"
set ssl_force_tls = yes
set ssl_verify_host = yes
set smtp_url="smtps://xxxxx@mailbox.org@smtp.mailbox.org:465"
#set smtp_url="smtps://xxxxx@mailbox.org@smtp.mailbox.org:587"
set smtp_pass="xxxxx"
set imap_user="xxxxx@mailbox.org"
set imap_pass="xxxxx"
set folder="imaps://imap.mailbox.org/"
set postponed="+Drafts"
set record="+Sent"
set spoolfile="+INBOX" 


Ich habe jetzt verschiedene Meinungen zum Port gelesen. Leider bekomme ich sowohl bei 465 als auch bei 587 Fehlermeldungen (Debugging mit neomutt -d1):


Port 465: <E> smtp_auth() Keine Authentifizierung verfügbar


Port 587: <E> tls_negotiate() gnutls_handshake: An unexpected TLS packet was received.

Hat da irgendjemand einen Vorschlag für mich?

Viele Grüße

Dennis

Kommentare (1)

Foto
1

Port 587 ist richtig, der Verbindungsaufbau scheitert aber am Handshake (siehe Fehlermeldung: Port 587: <E> tls_negotiate() gnutls_handshake: An unexpected TLS packet was received.)


So sollte es eigentlich funktionieren:

set from="username@mailbox.org"

set hostname="imap.mailbox.org"

set folder="imaps://imap.mailbox.org/"

set postponed="+Drafts"

set spoolfile="imaps://imap.mailbox.org/INBOX"

set ssl_force_tls = yes

set ssl_verify_host = yes

set smtp_url="smtps://username@mailbox.org@smtp.mailbox.org:587"

set smtp_pass="passwort"

set imap_user="username@mailbox.org"

set imap_pass="passwort"

set record="+Sent"

Foto
1

Hallo Daniel, danke für die Antwort - aber was unterscheidet denn Deine vorgeschlagene Konfiguration von meiner? Kann da jetzt keinen Unterschied entdecken 🤔

Foto
1

Hallo!

Ich hab folgendes in meiner .muttrc


set smtp_url = smtps://USER@mailbox.org:PASSWORT@smtp.mailbox.org

Foto
1

Hallo, guter Versuch - klappt bei mir leider auch nicht. Ohne Angabe des Ports kommt die Fehlermeldung wie oben für Port 465. Mit Angabe :587 am Ende kommt die Fehlermeldung für Port 587 wie oben beschrieben. Kann es sein dass mit gnutls selber etwas nicht stimmt?

Foto
1

1. smtps in smtp_url ist bei Verwendung von Port 587 (submission) falsch.

2. Zeigt neomutt -v bei compile options "+sasl" an? Ist libsasl/cyrussasl installiert?

Foto