Willkommen im User-Forum von mailbox.org
 

Mail-Adressen der eigenen Domain [bei mailbox.org] nutzen (Achtung: kein TLS!)

DMod hat dies geteilt, 19 Monaten her
veröffentlicht

Hallo,


als E-Mail-Anwender dachte ich, dass wenn ich die Anleitung zur Mail-Adressen der eigenen Domain nutzen ausführe, dann nutze ich auch für die Aliase von eigenen Domains via mailbox.org, die Transportverschlüsselung ( TLS) von mailbox.org.


Dem ist aber nicht so, wie ich vom Support nun erfuhr.


Als Anwender fände ich es richtig, wenn das in der Anleitung als Hinweis stehen würde, so hätte ich mir sehr viel Mühe gespart.


In der Anleitung sehe ich "nur" den Hinweise: "Die Nutzung unseres besonderen TLS-Versandes („@secure.mailbox.org“) ist mit eigenen Domains nicht möglich."


Auf den "besonderen TLS-Versand" hätte ich verzichtet, dass aber TLS generell bei eigenen Domains gar nichts mit mailbox.org zu tun hat, darauf bin ich von alleine nicht gekommen.


Bitte das in der Anleitung mit erwähnen.

Dank.

Kommentare (13)

Foto
1

Sorry, aber das ist hier total falsch und echter Quatsch.


Selbstverständlich kommt auch bei eigenen Domaisn voll und norma TLS zum Einsatz. Geht technisch gar nicht anders.


Nur der erzwungene Versand mit TLS, also secure.eigenedomain.de, geht nicht.

Foto
1

Na da bin ich aber froh! Ich kam heute ernsthaft ins zweifeln! Vor allem, weil ich das Feature auch anderen Leuten empfohlen habe.

Aber ich habe aus der Konversation mit dem Support den Schluss gezogen, dass TLS nicht zur Verwendung kommt.

Soll ich das hier posten?

Ansonsten, wie kann der Anwender die TLS Verbindung testen?

Wenn ich die Domain mit folgenden Services teste, kommt kein TLS verfügbar:

https://www.checktls.com

No Mail eXchangers found; will try TLS directly to host

TLS fail

https://de.ssl-tools.net/mailservers

DANE fehlt

PFS nicht geprüft

Heartbleed nicht geprüft

Schwache Algorithmen nicht geprüft

https://www.htbridge.com/ssl/

The server does not have SSL/TLS encryption on port 25. Data exchange with end-users can be intercepted.

The server does not have SSL/TLS encryption on port 993. Data exchange with end-users can be intercepted.

Mache ich etwas falsch?

Danke.


PS: mit den drei TLS Testseiten kommt meiner Erfahrung nach sonst ein Ergebnis heraus an dem man sich orientieren kann.

Foto
1

Hallo,

ganz sicher machst du etwas falsch. Es macht bei mir von der Verschlüsselung keinen Unterschied, ob ich meine Mailadresse der eigene Domain verwende, die ich über mailbox.org laufen lasse, oder ob ich meinen Mail-Alias mit mailbox.org-Adrese verwende. Mailbox.org hat Bestwerte bei der Konfiguration von TLS. Da können kaum andere Anbieter mithalten. Das ist auch so, wenn man die eigene Domain verwendet. Also machst du irgend etwas falsch.

Einzig ist, wie Herr Heinlein gesagt hat, die Transportverschlüsselungsgarantie nicht zu aktivieren mit der eigenen Domain. Man kann sich aber ein Email-Alias mit einer mailbox.org-Adresse zulegen, und bei diesem Alias dann die Transportverschlüsselungsgarantie aktivieren.

Nachtrag: Die Meldung

"No Mail eXchangers found; will try TLS directly to host"

lässt vermuten, dass du die MXe nicht (oder nicht korrekt) in den DNS-Einträgen deiner Domain gesetzt hast. Das ist in der Anleitung aber eigentlich ausführlich beschrieben.

Foto
1

Dann haben Sie wahrscheinlich Fehler in Ihrer DNS-Konfiguration.

Die Domain privacy-handbuch.de verwendet mailbox.org als Mailprovider via Aufschaltung als externe Domain. Schauen Sie sich die Testergebnisse für diese Domain an: TLS-Test der Mailserver für privacy-handbuch.de

Sie sehen: es werden die MX-Server von mailbox.org genutzt, TLS-Verschlüsselung ist auf dem Stand der Technik und DANE/TLSA ist aktiv.

Alles ok für diese Domain, daher sollten es bei korrekter Konfiguration auch für ihre Domain funktionieren.

Foto
1

Vielleicht könnten Sie Ihre Domain hier mal posten, dann könnte man nachschauen und Ihnen vielleicht sagen, was der Fehler in Ihrer Konfiguration ist.

Foto
1

Ich lese gerade nochmals Ihre Fehlermeldungen vom SSL-Text:

> No Mail eXchangers found; will try TLS directly to host


Eindeutig ein Fehler Ihrer DNS-Konfiguration. Sie haben für Ihre Domain die Mailserver von mailbox.org garnicht als MX-Server konfiguriert. Somitt wird IHR eigener Sever getestet und IHR Server unterstützt kein TLS.

Die Server von mailbox.org unterstützen TLS inklusive DANE/TLSA. Sie müssen nur ihre DNS-Konfiguration für Ihre Domain in Ordnung bringen. Siehe Anleitung in den FAQ.

Foto
Foto
1

Was genau testest du denn bei den genannten Seiten?

Sind deine DNS-Einträge sauber? Der ssl-tools Test beispielsweise sollte bei der Eingabe DEINER Domain die entsprechenden Server von mailbox.org prüfen. Bei mir ist das Ergebnis (natürlich) sauber:

mxext1.mailbox.org80.241.60.21210unterstützt *.mailbox.org DANE gültigPFS unterstütztHeartbleed nicht verwundbarSchwache Algorithmen nicht gefunden

Alternativ schaue dir doch mal die Header einer über deine (korrekt konfigurierte) E-Mail-Domain an.


Edit: viel zu langsam ;-)

Foto
1

Liebe Leute, danke für das Feedback.

Dass mailbox Bestwerte hat weiß ich und auch dass @secure.mailbox nicht verfügbar ist.

Mich haben 2-3 Aussagen des Support zu TLS generell bei eigener Domain verwirrt!

Nach dem das geklärt ist scheint in meinen Einstellungen das Problem zu liegen.

Die Domain ist bei namecheap.com registriert siehe hier:

https://support.mailbox.org/topic/mail-adressen-der-eigenen-domain-nutzen-namecheap

und Mails generell senden und empfangen geht.

Die Domain will ich hier nicht öffentlich posten. Schaue mir das also noch mal bei namecheap an.

Wenn ich hier https://www.htbridge.com/ssl/ teste, gebe ich z.B. meinedomain.tld:25 oder meinedomain.tld:993 ein.

Die angezeigte Server IP von meinedomain ist dann tatsächlich von namecheap nicht vom mailbox.org!

PS: Falls jemand einen Tipp zu namecheap Settings hat bitte gerne posten.

Foto
1

Ich würde der Einfachheit die ssl-tools verwenden. Diese schauen, welche MX-Records in den DNS-Daten deiner Domain hinterlegt sind, und prüfen dann die hinterlegten Mailserver. Das Bild sollte dann exakt dem entsprechen, wie es oben im Link vom Privacy-Handbuch ist.

Foto
1

Die Namecheap-Hilfe erklärt ganz unten bei Custom MX die Einstellung.

Typ: MX-Record

Host: @ (das ist deine Domain, sofern du keine Subdomain verwenden willst)

Value: mxext1.mailbox.org

Priority: 10

TTL: Automatic

Das gleiche dann für nochmal als weiterer Eintrag nur mit mxext2, und dann das gleich nochmal mit mxext3 und Priority 20, wie es in der Mailbox-org-Hilfe beschrieben ist.

Gleichzeitig solltest du vermutlich keine CNAME-Record für exakt diese Doimain (oder Subdomain) haben, weil der meines Wissens andere Einträge überschreibt.

Foto
Foto
1

10dc7313d84e218a044dcf6dcfd6964a


Es war so ein default CNAME-Record drinne, vielleicht lag es daran. Ansonsten hatte ich alles so gemacht, außer dass nur mxext1.mailbox.org eingetragen war.

Aber bis jetzt funktioniert TLS noch nicht, (2 Std. Wartezeit). Vielleicht noch etwas mehr Geduld.

Aber ist es nicht komisch, dass Mails senden/empfangen ohne TLS funktioniert!?

Foto
1

Es scheint so, also ob du bei dem eingefügten Bild (also bei den namecheap-settings) bei Host im Bereich der Mail-Settings (MXe) deine Domain eingetragen hättest. Wenn ich die Hilfe richtig verstehe, dann müsste da nur das Symbol "@" und zwar ohne Anführungszeichen stehen.

Beispiel: Ist deine Mailadresse name@example.org und ist die bei Namecheap registrierte Domain example.org, dann muss bei "Host" nur ein @ stehen, weil das die Domain ohne subdomains meint. Also das Symbol @ scheint bei Namecheap ein Kürzel für die Domain zu sein, und zwar ganz allgemein bei allen DNS-Settings (also nicht nur beim Mailbereich).

Beispiel2: Ist deine Mailadresse irgendwas@subdomain.example.org und hast du als Domain example.org registriert, dann sollte bei "Host" "subdomain" stehen, wieder ohne Anführungszeichen.


Warum du aber offenbar Mails wirklich empfangen kannst die an deine Domain-Mailadresse verschickt wurden (nur ohne TLS), da bin ich komplett verwirrt und überfragt. Sind die MXe falsch im DNS eingetragen, dann kann eine Mail eigentlich nicht zugestellt werden, zumindest nicht bei Mailbox.org, höchstens bei Namecheap. Dass das Mail verschicken geht, das ist klar, weil da loggst du dich ja direkt auf dem Mailbox.org-Server ein, und fragst nicht die DNS-Daten deiner Domain ab sondern verwendest nur die Domain als Absendername, der aber wie bei einem Postbrief alles enthalten kann, die Post geht trotzdem raus.


2 Stunden Wartezeit sollte eigentlich ausreichend sein dass sich die Änderung im DNS rumspricht, in absoluten Ausnahmefällen kann es aber tatsächlich auch mal länger dauern.


Zu den SSL-Tests ssl-tools.net vielleicht noch ein Hinweis: Bitte das updaten nicht vergessen. Bei der Standardabfrage kommt der letzte gespeicherte Wert. Da musst du dann auf aktualisieren klicken. Ich spreche aus leidvoller Erfahrung, habe das selber mal nicht geschnallt und geflucht, warum sich nix ändert.

Foto
Foto
1

Danke! Bei "Host" nur ein @, dann funktioniert es.

Auch der Tipp bei SSL-Tests ssl-tools.net "erneut prüfen" ist wichtig, reload der Webseite alleine tut es nicht. ;)


Das war eine Odyssee!