Willkommen im User-Forum von mailbox.org
 

Mails kommen nicht an bzw. gehen verloren

Robert hat dies geteilt, 2 Wochen her
beantwortet

Hallo zusammen,

leider habe ich ein Problem, das ich nicht schaffe zu beheben bzw. den Fehler einzugrenzen.

Vielleicht hat ja jemand ein paar Tipps wonach ich noch schauen könnte.

Ich nutze mailbox.org mit eigener domain domain.tld. Die MX-Server für die Domain zeigen auf mailbox.org. Versand und Empfang funktionieren.

Die Subdomain sub.domain.tld und die domain2.tld laufen *nicht* über mailbox.org, sondern über einen anderen Hoster. Die jeweiligen MX-Einträge zeigen auf den Mailserver des anderen Hosters. Die MX-Server-Einträge und Konteneinstellungen für sub.domain.tld und domain2.tld sind identisch. Versand und Empfang funktionieren. (Mit verschiedenen Anbietern getestet)

Das Problem ist jedoch folgendes:

Mails, von user@domain.tld (bei mailbox.org) anuser@domain2.tld (beim anderen Hoster) geschickt, kommen an.

Mails, von user@domain.tld (bei mailbox.org) an user@sub.domain.tld (beim anderen Hoster) geschickt, kommen *nicht* an. Es gibt keine Fehlermeldung, Bounce oder ähnliches.

Der Hoster von sub.domain.tld konnte in den Mailserverlogs auch nicht finden, dass eine Zustellung an user@sub.domain.tld von user@domain.tldversucht wurde.

Den support von mailbox.org habe ich vor 3 Tagen auch kontaktiert, aber leider bisher keine Antwort erhalten. Das Ticket hängt seit 2 Tagen auf „Waiting for first level“.

Hat noch jemand eine Idee, wie ich ohne Hilfe durch den Support auf Fehlersuche gehen könnte?

Falls der Fehler wirklich auf Versandseite liegen sollte, habe ich ein wenig Bedenken, dass nicht nur dieser Empfänger betroffen ist und ich es nur nicht merke, wenn einige meiner Mails nicht ankommen.

Vielen Dank schonmal

Robert

Kommentare (7)

Foto
1

Dein für die Subdomain beim anderen Provider genuzter Mailserver ist kaputt und liefert Timeours.

Jan 4 11:09:42 mx1 postfix/error[3126221]: 14D974BB3D: to=<notes@xxxxxxx>, relay=none, delay=56901, delays=56873/28/0/0, dsn=4.4.2, status=deferred (delivery temporarily suspended: conversation with xxxxxxxx[2a00:d0c0:xxxxxxxxxxxx] timed out while receiving the initial server greeting)

Mailbox.org hat damit nichts zu tun.

Mehr in Deinem Ticket.

Foto
1

Leider ist die Situation nun so, dass sich mailbox.org und der andere Provider beide relativ sicher sind, dass das Problem beim jeweils anderen liegt.

Ich hatte dazu auch noch ein paar Infos an den Support geschickt, aber leider steht das Ticket nun seit einer Woche auf "Waiting for first level". Ich befürchte log-Einträge, die weiterhelfen könnten sind damit dann gelöscht?

Foto
Foto
1

Hallo Peer,

Vielen Dank für die schnelle Hilfe. Ganz allgemein: ohne Support für mich nicht möglich zu erkennen, oder? Wollt Ihr nicht doch Mailtrace wieder auf die Agenda setzen ;) (wobei ich verstehe wenn es dafür keinen sinnvollen Businesscase gibt, aber cool wäre das Feature schon).

Vielen Grüße

Robert

Foto
1

Es giobt dafür einen sinnvollen Businesscase, aber sowas dauert > 1 Mannjahr (und im alten Mailtrace stecken rund 4 Mannjahre) und wenn keine Entwickler da sind kann man sogar Geld und Business Case haben, wie man will: Man kann nur jeden Tag neu überlegen, was man NICHT macht.

Egal wie: Irgendwelche Nutzer regen sich dann immer auf wie "unmöglich" es ist, daß Feature XY angeblich Basic/Selbstverständlich ist und nicht genau so geht, wie sie es wünschen. Alles kostet aber Entwicklungszeit. Und solange ist Mailtrace ein Luxus.

Gib mir drei Entwickler und Du kriegst es.

Aber: Doch, es ist für Dich zu erkennen. Mailserver haben eine "Queue Lifetime" und sobald die abgelaufen ist, geht die Mail auch mitsamt Fehlermeldung zurück. Mails gehen schließlich nie verloren.

Foto
1

Guter Punkt. An die Queue Lifetime hatte ich nicht gedacht, die meisten Konfigurationsfehler führen ja eher zu einer direkten Ablehnung mit entsprechender Fehlermeldung, und da die nicht gekommen ist, war ich etwas verwundert. Über die Fehlermeldung nach Ablauf der Queue Lifetime Fehlersuche zu betreiben ist aber auch eher anstrengend, da man zwischendurch immer etwa eine Woche Pause machen muss :)

Was die Entwickler angeht: Schade, aber leider ein bekanntes Problem in einigen Bereichen ... Ich rege mich auch nicht auf, dass ein kein Mailtrace gibt, sondern fände es einfach ein extrem cooles Tool, tatsächlich eher im Bereich Luxus, aber ich mag Luxus :) So ein Feature habe ich außer bei den kostenpflichtigen Accounts bei dem großen Suschmaschinenanbieter auch noch nicht gesehen.

Vielen Dank und schönes Wochenende

Foto
1

Timeouts und "host unreachable" sind keine fatalen, sondern nur temporäre Timeouts, da man ja davon ausgeht, daß sich das Problem lösen wird. Mailserver werden sowas also nicht sofort bouncen.

Unsere Queue-Lifetime beträgt derzeit maximal 3 Tage, zukünftig eventuell 2.

Foto
1

Danke für die Info. Ich hatte einfach keine Timeouts oder temporäre Fehler erwartet, da eine andere Domain auf dem gleichen Host völlig problemlos funktioniert und Mails von anderen Absendern auch ankommen.

Was der Grund für den Fehler ist, kann ich noch nicht sagen, da ich noch auf die Rückmeldung des Supports beim anderen Hoster warte.

Die ersten Fehlermeldungen sind jetzt mach Ablauf der Queue-Lifetime übrigens auch angekommen.

Foto