Willkommen im User-Forum von mailbox.org
 

mehrere Bedingung in Filtern

8918807 hat dies geteilt, 5 Monaten her
veröffentlicht

Ich habe das Problem, dass seid ich eine zweite Bedingung in meinen Filter aufgenommen habe, dieser nicht mehr funktionier.

Ich möchte im Feld "Von" alle emails die auf "@xyz.de" enden und die auf "@xyz.com" enden in einen sepparaten Ordner speichern. Leider funktionierte das nur mit einer Bedingung, seid die zweite hinzugekommen ist funktioniert der Filter nicht mehr. Ich hatte eingestellt, das nur eine Bedingung zutreffen muss.

Hat jemand eine Idee woran das liegen kann?

Beste Antwort
Foto

Im mailbox.de-Webinterface kannst du für eine Mail unter ≡ (Weitere Aktionen) / Quelldaten anzeigen die ungefilterten Mail inklusiver aller Header ansehen. Wenn du den FROM: Header betrachtest, enthält er nicht nur die reine eMail-Adresse sondern üblicherweise auch noch Vor- und Nachname bzw. Firmenname. Also zum Beispiel "Max Mustermann <max@test.de>".

Eine Regel mit "Von enthält" oder "Von endet auf" testet den ganzen FROM-Header inklusive allen Beiwerks. Es ist also nicht ganz einfach damit eine Adresse zu filtern. Besser ist die Anschrift-Bedingung geeignet, die extrahiert die eMail-Adresse und du kannst gezielt auf die ganze Adresse oder Teile davon (wie z.B. die Domain) prüfen

Übrigens kann der Absender FROM: ganz leicht fälschen, besser sollte man den Envelope-Von prüfen.

In https://www.bernhard-ehlers.de/blog/posts/2020-02-11-mailbox.org-email-filter.de/ habe ich komprimiert die Bedeutung der Filterregeln zusammengefasst.

Kommentare (1)

Foto
1

Ich würde einfach zwei Filterregeln einrichten mit je einer der Bedingung und es sollte klappen. Einfach mal versuchen und ich denke es wird funktionieren.

Foto
1

Ich versuche gerade eine Umstellung auf "enthällt" statt "endet auf", wenn das auch nicht geht versuche ich zwei Filter.

Mich würde dennoch interessieren warum der oben beschriebene Filter nicht geht, da ich wenig Lust verspüre meine Zeit mit ausprobieren der Filter zu füllen. Vielleicht ist es ja auch ein Bug bei dem man froh ist wenn er gemeldet wird :-)

Foto
1

Das ist ein wenig schwierig zu sagen ohne den Quellcode der E-Mail zu sehen. Aktuell verwende ich die Filter basierend auf „VON“ mit der Bedingung „enthält“. Wichtig ist es bei den Bedingungen immer jegliche Leerzeichen etc. nicht zu kopieren. Das sollte eigentlich funktionieren.

Und wie gesagt würde ich immer separate E-Mail Filter anlegen, insbesondere auch wenn die nachher unterschiedlich behandelt werden sollen (auch wenn das bei Dir noch nicht der Fall ist).

Foto
1

Danke dir schon mal, ich werde berichten.

Foto
1

Ob ein Filter mit 2 Bedingungen wie gewünscht funktioniert, dürfte davon abhängen, ob die Regel angewandt werden soll, wenn eine Bedingung erfüllt sein soll, oder ob beide Bedingungen erfüllt sein müssen. Letzteres kann bei 2 unterschidl. Domains wie im Beispiel oben nicht funktionieren.

Foto
1

Deshalb hatte ich eingestellt, dass eine der beiden Bedingungen zutreffen muss, nicht beide.

Foto
3

Im mailbox.de-Webinterface kannst du für eine Mail unter ≡ (Weitere Aktionen) / Quelldaten anzeigen die ungefilterten Mail inklusiver aller Header ansehen. Wenn du den FROM: Header betrachtest, enthält er nicht nur die reine eMail-Adresse sondern üblicherweise auch noch Vor- und Nachname bzw. Firmenname. Also zum Beispiel "Max Mustermann <max@test.de>".

Eine Regel mit "Von enthält" oder "Von endet auf" testet den ganzen FROM-Header inklusive allen Beiwerks. Es ist also nicht ganz einfach damit eine Adresse zu filtern. Besser ist die Anschrift-Bedingung geeignet, die extrahiert die eMail-Adresse und du kannst gezielt auf die ganze Adresse oder Teile davon (wie z.B. die Domain) prüfen

Übrigens kann der Absender FROM: ganz leicht fälschen, besser sollte man den Envelope-Von prüfen.

In https://www.bernhard-ehlers.de/blog/posts/2020-02-11-mailbox.org-email-filter.de/ habe ich komprimiert die Bedeutung der Filterregeln zusammengefasst.

Foto
1

Danke für die sehr guten Hinweise!

Die Quelldaten enthalten ja einiges an Zeichen, ist etwas aufwendiger da duchzublicken. Aktuell scheinen meine Filter mit der Änderung von "Endet auf" auf "Enthält" zu funktionieren, ich passe sie trotzdem auf deine Hinweise an um auch in Zukunft weniger Probleme beim Filtern zu haben.

Foto
1

Wenn ich nach dem Feld "Envelop-Von" filtere funktionieren meine Filter wieder nicht. Bei mir funktioniert das Filtern einer Absenderdomain wenn ich das Feld "Von" verwende und dort "enthält" auswähle.

Foto