Willkommen im User-Forum von mailbox.org
 

OTP Login Backend

zapata hat dies geteilt, 7 Monaten her
unbeantwortet

Hi,

war das gestrige Update am OTP Login Backend erfolgreich oder wurde es wieder rueckgaengig gemacht? Im Moment dauert die Anmeldung wieder sehr lange (oder noch immer?) und bis heute Nachmittag wurde unter Settings -> Mailbox.org -> One Time Passwords bei mir keine Tokens sondern nur eine Anmeldemaske angezeigt.

Danke.

Kommentare (2)

Foto
1

Etwas ankündigen aber dann nicht berichten ist schon sehr merkwürdig.

Scheint Probleme zu geben, sonst hätten wir schon was gehört

Foto
1

Wir haben einen internen technischen Change angekündigt. Auf der Liste für Leute, die alles wissen wollen. Wenn alles glatt geht, dann hat dieser interne Change keinerlei Auswirkungen nach außen.


Derartige Changes nehmen wir ca. 10 bis 25 mal am Tag vor. Alleine heute morgen habe ich schon 4 durch.


Wenn es eine Auswirkung auf User haben /könnte/ dann informieren wir auf dem entsprechenden Tech-News-Verteiler.


Wir haben aber nicht vor über jeden Handgriff eines 40köpfigen Teams zu informieren und wir werden nach einer solchen Information auch nicht jedes mal eine Rückmeldung geben; insb. wäre ja nur zu sagen: "es hat sich (für den User) nichts geändert".


Es hat keine Probleme gegeben. Ich fände es extrem uncool, wenn unsere Transparenz jetzt wieder Mystiken und Negativ-Theorien befeuert. Hier ist absolut nix merkwürdig.

Foto
2

Das mag alles soweit richtig sein und sehe ich auch ähnlich. Man muss und sollte nicht alles kommunizieren.

Aber wenn man etwas groß (auch via Twitter) ankündigt - ohne Zeithorizont und ohne Info ob es einfach so durchläuft usw. - dann darf man doch wohl noch nachfragen. Vor allem dann wenn sich User zurückmelden, bei denen es in diesem Bereich anscheinend weiter Probleme gibt.


Ihr macht einen super Job - aber an der Informationskultur müsst Ihr auf jeden Fall noch arbeiten. Das sollte man an der Stelle ruhig einmal sagen dürfen.

Foto
1

Gerade wurde mir wieder ein "Connection timeout" nach der Anmeldung angezeigt. Also für mich hat sich in der Tat nichts geändert. Sorry! Aber wenn nur ich das Problem habe, dann wird's schon passen. :-)

Foto
1

Auf Twitter war Maintenance angekündigt, da wir intern Server und Konfiguration gewechselt haben. Wir haben keinen Update am OTP-Backend angekündigt.

Foto
1

To: <removed>@mailbox.org

Subject: [mailbox.org system operations] OTP login back-end update today, 16 June 2020, from 14:00 CET

From: "mailbox.org Info-Mail" <noreply@mailbox.org>

Date: Tue, 16 Jun 2020 11:03:47 +0200


Dear mailbox.org customers,


In order to improve the security and speed of the mailbox.org login

process via OTP (One-Time-Password), we will be making some modifications

to the OTP authorisation access point.


As a result of this change, the login process will use a smaller and

leaner data set in the future, which improves general data economy and

promises better performance. The update is scheduled to be implemented

today, Tuesday 16 June 2020, from 14:00 hours CET.


The new system has been extensively tested in advance, and we are not

expecting any significant impact on services in operation. However, users

might experience brief interruptions of the login functionality while we

are working on this important update. Please accept our apologies if this

causes any inconvenience.


With kind regards,

Your mailbox.org team


PS: You have received this newsletter because you have registered for it

in the mailbox.org office. There you can unsubscribe from this

information at any time: https://login.mailbox.org/en


Our data protection & privacy policy can be found here:

https://mailbox.org/en/data-protection-privacy-policy

Foto
1

Richtig. Diesen Text habe ich geschrieben. Vielen Dank, was auch immer Du mir damit beweisen möchtest.

Wir haben trotzdem kein Update am Backend vorgenommen, sondern nur das benutzte Dataset verkleinert ("modification"). An der verwendeten Software, der Strageie und Co selbst hat sich nichts geändert.

Diese Diskussion zeigt hervorragend, warum wir besser doch keine kleinschritten technischen Infos über Alltags-Changes an Nutzer heraussenden sollten. Schade. Wir haben ein Dutzend solcher Changes jeden Tag. Die Notification ging an den Tech-News-Verteiler raus, weil es (für sehr kurze Zeit) zu Login-Haklern hätte kommen können. Nicht mehr, nicht weniger.

Wenn jede zu ewigen Diskussionen, Missmut und am Ende noch "Beweisversuchen" gegen uns selbst (sic!) führt, dann sollten wir das mti der Transparenz hier wirklich besser lassen. Nochmal schade.

Foto
1

Gerade wieder: Es dauerte > 30 Sekunden (gefuehlt) bis meine Inbox (ca. 1500 Mails; 105MB) angezeigt wurde; aber immerhin diesmal kein Connection time-out. Ich werde mir fuer das naechste Mal eine Stoppuhr bereitlegen. :)

Foto
3

Ich habe das Gefühl, dass hier ein wenig aneinander vorbeigeredet wird. Das Missverständnis scheint daher zu rühren, dass bei Twitter in der Tat keine Bauarbeiten am OTP-System angekündigt wurden, sondern andere Wartungsarbeiten, die zumindest nicht direkt damit im Zusammenhang standen.

Die Transparenz über anstehende Wartungsarbeiten finde ich grundsätzlich sehr gut und bin dankbar dafür.

Vielleicht wäre es hilfreich, sämtliche herausgegebenen Hinweise an einer zentralen Stelle, z. B. der Statusseite, zu bündeln, um Verwirrung und Verwechselungen zu vermeiden. Diese könnten dann wie bisher fallweise in einer E-Mail an die breite Mailbox.org-Öffentlichkeit oder die interessierteren Tech-Menschen verbreitet werden. Auch bei Twitter könnte auf die Wartungshinweise verlinkt werden: So behielten alle Beteiligten den Überblick, würden so intensiv informiert wie gewünscht und bei Mailbox.org fiele keine Mehrarbeit im Vergleich zum Status quo an.

Das konkrete Problem von zapata ließe sich durch eine Supportanfrage womöglich besser lösen als an dieser Stelle.

Foto
1

Im Subject der E-mail : "OTP login back-end update today" und im Body dann: "The update is scheduled to be implemented today" und "while we are working on this important update."


Und hier: Wir haben trotzdem kein Update am Backend vorgenommen,

Da ich kein Hellseher bin, kann ich nicht wissen, was ihr genau gemacht habt. Fakt ist, dass die Anmeldung noch immer teilweise sehr lange dauert und auch Fehler ausspuckt (better performance?). Aber vielleicht müssen wir/muss ich einfach noch ein paar Wochen/Monate/Jahre darauf warten bis die Anmeldung zuverlässig funktioniert!

Foto
1

Ja, Du hast recht, da hat unser Marketing-Team beim Übersetzen von DE nach EN unglückliche Worte gewählt weil User gerne das Wort "Update" falsch verstehen und in seiner Dimension nicht richtig einschätzen. Es war ein Update an der Config, es war aber kein Upgrade und auch keine Migration/KEIN Wechsel der kompletten OTP Login Infrastruktur gewesen. Egal, was Du mir beweisen willst. War es nicht. Ich würde es wissen, wenn es das gewesen wäre.

Ich kann Deine Timeoutfehler nicht nachvollziehen. Wir haben > 100.000 User aktiv und monitoren rund 30.000 Messwerte. Was mit Deinem persönlichen Internet-Zugang los ist weiß ich nicht, aber diese Timeouts sind nicht normal und wir können aus keinem anderen Fall > 30 Sekunden nachvollziehen. Auch die Menge der E-Mails in der INBOX hat damit nichts zu tun, das hat keinen Einfluss auf die Zeit.

Richtig ist, daß der OTP-Login derzeit absichtlich 3 Sekunden Delay hinlegt um die Synchronisation zu ermöglichen. Richtig ist, daß wir das Dataset verändert haben um zu sehen, ob damit die Synchronisation schneller wird (was aber am hardcodierten 3 Sekunden-Timeout nichts ändert). Richtig ist, daß ein Rewrite des OTP-Login-Mechanismus erst durch das Update auf OX 7.10.3 möglich geworden ist und richtig ist, daß wir das erst in den nächsten Monaten in aller Ruhe angehen werden.

Mit 30 Sekunden Timeout hat das aber alles nichts zu tun. Persönlichen Support gibt's im Helpdesk.


Ich würde diese ziemlich nervtötende müßige Diskussion gerne beenden: Es ist Wochenende, es gibt Familie, es gibt viel zu tun. Danke.

Foto
1

1. Ich wollte eigentlich keine Diskussion führen, nur wissen, ob sich was bei der OTP Anmeldung bei anderen Nutzern geändert/verbessert hat. Verwundert war ich auch, dass 1-2 Tage statt meines Tokens nur eine weitere Login Maske angezeigt wurde.

2. Ich habe jetzt OTP temporär deaktiviert, die Anmeldung scheint jetzt wesentlich zügiger zu funktionieren.

3. Liegt wohl eher nicht an meinem Internetzugang... aber ich schau mal ob ich meinen 300/30 Mbit Anschluss zu Hause bzw. unseren 1 GBit/s Anschluss (synchron) im Büro upgraden kann... die Anmeldeseite und die Inbox selbst funktionieren allerdings problemlos... und IMAP4 funktioniert auch super.

4. Ich befürchte, dass ich über den Support eine ähnliche Auskunft erhalten werden (alles super, liegt sicher an ihrem Internetanschluss).

5. Schönes/Erholsames Wochenende!

Foto
1

Ich kann es kaum erwarten, dass die TImeoutfehler a) wenigstens mal anerkannt werden und b) dann irgendwann behoben werden. Ich habe mir vorgenommen, von dem ganzen Vorgang mal einen Screencast zu erstellen, bei dem man dann die bis zu 4-5 Loginversuche hintereinander sehen kann, schön mit Zeitstempeln.

Foto
1

Ich werde meinen Account demnächst kündingen. Ich bin zwar vom Mailbox.org Konzept überzeugt und würde auch voll dahinter stehen. Aber die Qualität die hier ausgeliefert wird ist doch oft Mangelhaft. Sicher sind oft die "anderen" Schuld. Die Internetleitungen, Open Xchange, der Bug hier der Bug da und irgendwann wenn du User Glück hast wird er auch gefixt. Noch nie nie habe ich aber gehört, lieben Kunden wir wissen das unser Produkt hier und da nicht richtig funktioniert, wir sind dabei und bis dahin zahlt Ihr auch nur einen Teil eurer Gebühren. Ich weiß jetzt kommt gleich wieder " 1 Euro ist so wenig , das wir eh damit nichts verdienen" Das kann ja aber auch nicht das Problem des Kunden sein.

Foto
1

Hallo Rene,

der Screencast davon würde mich *sehr* interessieren. Wir sehen diese Timeouts hier in unseren Testcases und unserer Belegschaft nicht, können das nicht nachvollziehen und haben keine qualifizierten / nachvollziehbaren Reports dazu.

Bekannt ist, daß manchmal "Session-Passwörter" bei OTP-Logins nicht schnell genug im Cluster repliziert werden, so daß man anschließend in OX eingeloggt ist, dieser aber ggf. zwei/drei Versuche braucht, bis er seinerseits die IMAP-Verbindung zum Mailabruf aufgebaut hat. Da kommt dann eine etwas verwirrende (und falsche) Meldung, ob ggf. gerade kurz vorher das Passwort geändert wurde (was inhaltlich ja sogar stimmt, weil wir ja session-Passwörter setzen).Daran arbeiten wir derzeit; durch das neulich verkürzte Dataset wollen wir die Replikationszeit verkürzen bzw. mit OX 7.10.3 wollen wir / können wir jetzt endlich in den nächsten Monaten sauberes FIDO & U2F & Co neu implementieren.

Das hat aber nichts mit einem echten Timeout zu tun, wo man (wenn ich Dich richtig verstanden habe) nicht in OX reinkommt. Das können wir nicht nachvollziehen und ist uns wie gesagt nicht qualiifiziert bekannt -- würden wir uns aber sofort mit Hochdruck anschauen, wenn wir es nachvollziehen könnten. /Eigentlich/ gibt es an der Stelle auch keinen Unterschied zwischen OTP- und Normalpasswort, so daß ich jetzt auch erstmal nicht wüßte, wieso das mit OTP anders sein soll, als normal. Darum: Jede Hilfe und jeder Hinweis ist willkommen.

Vermutlich wäre es das besten, wenn dabei auch einmal (in Firefox) die Webentwicklerkonsole mit geöffnet wäre (Extras => Webentwickler => Netzwerkanalyse).

Wenn Du da einen Mitschnitt hast schicke ich Dir gerne einen Uploadlink, falls Dein eigenes Drive nicht genug hernimmt; bzw. ich nehme auch Mails mit 100 MB Attachment gerne an... Danke für Deine Unterstützung!

Foto
1

Ich habe gerade wieder folgendes Problem:

Anmeldung fehlgeschlagen:

ErrorThere was an issue while authenticating. This may be due to a recent password change. To continue please log out and log back in with your most current password.

Bis auf den Zugriff auf E-Mails scheint alles zu funktionieren: Kalender, Adressbuch, Tasks, Einstellungen, Drive etc.

Foto
1

Gerade trat das Problem wieder auf: bisher bei 2 von 3 Anmeldeversuchen. Nervig!


Foto
1

Ich weiß zwar nicht was hinter dieser Fehlermeldung steckt, aber sowas fördert nie das Vertrauen in einen Anbieter. Zumal das Problem ja augenscheinlich auch schon länger bekannt ist

Foto