Willkommen im User-Forum von mailbox.org
 

Sieve Verbindung nicht möglich

9588184 hat dies geteilt, 2 Jahren her
veröffentlicht

Guten Tag!

Ich versuche die Sieve-Filter Regeln vom Server abzurufen kann mich aber nicht verbinden. Es kommt weder eine Fehlermeldung noch irgendein Hinweis. Port 4190 wird verwendet und die Standard IMAP Zugangsdaten.

Kommentare (23)

Foto
1

imap.mailbox.org / 4190 / STARTTLS?


Lokale Firewall? Lokale Firewall im Router?


Port und Server sind up&running:


peer@flashback ~ $ telnet imap.jpberlin.de 4190

Trying 91.198.250.9...

Connected to imap.jpberlin.de.

Escape character is '^]'.

"IMPLEMENTATION" "Dovecot Pigeonhole"

"SIEVE" "fileinto reject envelope encoded-character vacation subaddress comparator-i;ascii-numeric relational regex imap4flags copy include variables body enotify environment mailbox date index ihave duplicate vacation-seconds imapflags notify vnd.dovecot.pgp-encrypt"

"NOTIFY" "mailto"

"SASL" "PLAIN LOGIN CRAM-MD5 DIGEST-MD5"

"STARTTLS"

"VERSION" "1.0"

OK "Dovecot ready. Master."

^]

telnet> quit

Foto
1

Lokale FW - aus

FW Router Regel hinterlegt

kein Proxy

40924b89f62b999dd6992412d2065680

Foto
1

Was passiert wenn Du das manuell mit telnet versuchst? Kannst Du das mal prüfen -- ggf. auch so in der Windows-Kommandozeile?


telnet imap.jpberlin.de 4190


Ansonsten ist das aber ab hier ein Fall für den Individualsupport unter support@mailbox.org. Es müßte so gehen, bei Dir steht aber irgendwas auf der Leitung.

Foto
1

Hi sieht für mich gut aus:

"IMPLEMENTATION" "Dovecot Pigeonhole"

"SIEVE" "fileinto reject envelope encoded-character vacation subaddress comparator-i;ascii-numeric relational regex imap4flags copy include variables body enotify environment mailbox date index ihave duplicate vacation-seconds imapflags notify vnd.dovecot.pgp-encrypt"

"NOTIFY" "mailto"

"SASL" "PLAIN LOGIN CRAM-MD5 DIGEST-MD5"

"STARTTLS"

"VERSION" "1.0"

OK "Dovecot ready. Master."

Foto
1

Und mit imap.mailbox.org?

Foto
1

Hi!

Ja auch mit imap.mailbox.org geht's per telnet

Foto
1

Bei mir funktioniert das auch alles ohne Workaround. Der Client kann sich auch anmelden, dann aber hängt die Verbindung.


Wenn das bei dir auch der Fall ist, hilft vielleicht das Setzen von TcpAckFrequency und/oder TCPNoDelay. Das geht unter Windows allerdings nur in der Windows Registry. :-(


@mailbox.org: ein Fehler auf eurer Seite könnt ihr 100% ausschließen?

Foto
1

Sieht für mich so aus, als ob die Verbindung nicht hergestellt wird / Die Einstellungen hab ich mal in der Registry für meine NIC gesetzt (deaktiviert). Leider aber das selbe Problem

fe4ec6e124af27b8b1ba67d4cb7f2988

Foto
1

Hallo,


ich sehe, daß Du Dich hier die ganze Zeit erfolgreich mitsamt TLS & Co per Managesieve erfolgreich (!) einloggst. Wenn das weiß bleibt, dann ist das was in Deinem Thunderbird oder Plugin. Da scheint mir das Sieve-Plugin oder sowas buggy zu sein.


Ich habe so ein deja-vu daß es das vor Jahren schonmal gab, daß das Sieve-Teil kaputt war und weiße Seiten warf.


Wie auch immer: Das Problem liegt bei Dir im Thunderbird, davon bin ich fest überzeugt. Updaten, upgrade, verhauen, rebooten, beten oder mit Gummibärchen werfen: Schau, was da hilft.

Foto
1

Hallo!? Die Verbindung/Client scheint zu haengen (Cursorsymbol; keine Verbindunginfos). Das Problem habe ich eben auch! Ich kann mich verbinden, nur dann wird das Sieve Script nicht geladen. Wenn ich Glueck habe funktioniert es 1x von 20 Versuchen. Das Problem tritt auch auf einem Server mit oeffentlicher IP Adresse und ohne Firewall auf. Anfrage habe ich am 4. November an eureren Support gerichtet. Da hiess es nur "Support für individuelle Clients können wir an dieser Stelle nicht anbieten. Wenn Sie Probleme mit dem Webmailer haben, helfen wir Ihnen gern weiter.". Dass der Fehler bei euch liegt, kann natuerlich nicht sein!

Foto
Foto
1

Ich habe möglicherweise ein (ähnliches) Problem mit Emacs (sieve-manage) unter FreeBSD.

Bei mir hilft:


# sysctl net.inet.tcp.delacktime=70

oder

# sysctl net.inet.tcp.delayed_ack=0


Vom Support kam wie so oft nur "unterstützen wir nicht".

Foto
1

Vielen Dank für deine Antwort.

Da Sieve für mich neu ist, aber eigentlich davon ausging, dass es für leicht machbar sein sollte die Regeln zu defienieren, hab ich keine Ahnung, wo ich diese Einstellungen machen kann.

Ich verwende ein Thunderbird Plugin, da es mir am einfachsten erschien. Dort finde ich den Settings nicht wirklich etwas ähnliches...

Foto
1

Es IST auch einfach und da gibt es auch nichts besonderes. Aber ich kann nicht hellsehen ob/was da an lokalen Windows-Firewalls und Co irgendwelche Verbindungsdaten blockt.

Foto
1

- Probier mal Port 2000 statt 4190.

- Telnet schon probiert?

- Kannst du mal mit Wireshark den Traffic (port 4190 oder 2000) mitprotokollieren? Kommen da Pakete retour?

Foto
1

Telnet ja geht. auch mit imap.

Port 2000 hatte ich ebenfalls schon probiert.

Wireshark gut und recht, aber wie ich da die Filter so hin hinbekomme, dass nur 4190 bzw. 2000 gefiltert wird, weiß ich jetzt nicht. Ich sehe das Programm das erste Mal.

Foto
1

Hallo,

bei Thunderbird kann es helfen in den Sieve Einstellungen unter Proxy "Direkte Verbindung" einzustellen, auch wenn im System kein Proxy konfiguriert ist.


Bei mir funktioniert es ohne Probleme. Thunderbird unter Windows mit Sieve Plugin.

Foto
1

Wärst du vielleicht so nett und würdest mal deine Versionen posten (TB und Sieve Plugin)

Die Proxyeinstellung hat bei mir ebenfalls nichts gebracht

Danke.

Foto
1

Hallo,

aktuell setze ich Thunderbird 45.7.0 und das Sieve Plugin mit der Version 0.2.3d ein.

Foto
1

Hi!

Vielen Dank für die Info! Mit der neuesten Nightly Build (k) funktioniert es bei mir auch. Offiziell ist über den Plugin Manager nur die Version 2.2 erhältlich.

Foto
1

Hast du es mehrfach probiert? Ich habe es gestern ueber den Tag ca. fuenfzehn mal versucht und es hat nur einmal funktioniert. :-( Ich verstehe leider noch immer nicht, wieso ich nur fuer Mailbox.org (Sieve) net.inet.tcp.delacktime (<= 70) bzw. net.inet.tcp.delayed_ack=0 setzen muss, damit es zuverlaessig funktioniert.

Foto
1

Hi!

Ja wie gesagt, mit den neuesten Versionen funktioniert es einwandfrei. Jedesmal. Ich habe bereits meine Regeln so angepasst und bin vollauf zufrieden.

Foto
Foto
1

Seit etwa dem 7. April 2017 ist es für das Sieve-Addon von Thunderbird nötig die neueste Version 0.2.3L zu verwenden, die jemand auf Github zur Verfügung stellt. Der Grund sind Änderungen in Thunderbird, mit denen die ältere Versionen des Addons nicht mehr funktioniert. Bei mir funktioniert Sieve mit 0.2.3L einwandfrei. Ich musste keine weiteren Einstellungen im Addon ändern, und auch keine TCP-Einstellungen ändern.

Foto
2

Mit der Version des Sieve-Plugins für Thunderbird, die in der Add-ons Suche angeboten wird, ging es bei mir nicht (ein SASL Fehler). Mit der Version, die hier zum Download steht (0.2.11) geht alles wunderbar.