Willkommen im User-Forum von mailbox.org
 

Suche in E-Mails

9099556 hat dies geteilt, 21 Monaten her
kein Problem

Die Suche im Reiter E-Mail findet keine Wörter in E-Mails. Überprüft mit Wörtern, die sicher in vorhandenen E-Mails auftauchen. Weder im Posteingang noch in "Allen Ordnern".

Hier ein Beispiel mit der Suche nach dem Wort "du", welches garantiert in vielen meiner E-Mails auftaucht:

/510d437ec5b01884a752224fbd834005

Kommentare (29)

Foto
1

Ich habe ebenfalls dieses Problem. Gibt es dafür bald eine Lösung? K-9 Mail findet die Nachricht problemlos. Ich habe derzeit nur 148 Nachrichten in meiner Inbox. Lächerlich.

Foto
1

Eben nachgestellt klappt einwandfrei. Suchbegriff eingeben und dann vorgeschlagene Suchkriterien wählen. Hier suche ich nach "Überweisungszweck" und wähle "in E-Mail-Text"0eab096ce9a342ca22bd7206c7d2a030


Ergebnis findet genau das Gewünschte.

e4f54d88e557e80e1a3de0bf683db35e

Foto
1

Freut mich, dass es bei Ihnen funktioniert! :) Aber auch andere User haben bereits gemeldet, dass das nicht richtig funktioniert. Wenn ich nach einem anderen String aus der E-mail suche, wird die E-mail gefunden.

Foto
1

Also nach unserem Kenntnisstand funktioniert das seit Monaten einwandfrei. Ich kann mich auch nicht erinnern daß es diesbezüglich relevant und nachvollziehbare andere Rückmeldungen gegeben hätte.


Eine Mindestlänge gint es nicht; aber wie jeder Volltextsuchindex gibt es nicht suchbare "Stopwords". Das ist dann aber sowas wie "und", "aber" oder "sowieso".


Außerdem besteht natürlich die Möglichkeit, daß das von Dir gesuchte Wort so gar nicht in der E-Mail steht, beispielsweise, weil es HTML oder base64-codiert ist und physikalisch anders gespeichert ist.


Ohne konkretes Beispiel kann ich das nicht nachvollziehen.

Foto
1

Die Nachricht ist tatsächlich base64-codiert.

Komisch aber, dass ein String aus der Nachricht gefunden wird und ein anderer nicht. Wenn ich die Nachricht per copy&paste in einen Editor übertrage und dann nach dem String suche, wird er nicht gefunden. Also wird der base64-codierte Teil offenbar doch durchsucht.

Ich habe dazu gestern ein Ticket erstellt: 2017121310001465.

Anderer User mit dem Problem:

https://support.mailbox.org/topic/suche-nach-mails#comment-9758

Foto
1

Ich habe ein paar Screenshots gesendet.

Foto
1

Und alles sofort als "Kein Problem" markieren...

Foto
Foto
1

Das Problem besteht in der Auswahl der Suchkriterien. Gebe ich nur den Suchbegriff im Suchfeld ein, werden keine oder nur wenige Suchtreffer angezeigt.

Begrenze ich dagegen die Suche auf "im Betreff" oder auf "im E-Mail-Text" werden nun deutlich mehr Treffer angezeigt.

Wobei die Suche mit Filter "im E-Mail-Text" bei mir deutlich länger braucht und über sämtliche Ordner hinweg gar nicht funktioniert ("502 Proxy Error").


Nachtrag: Sehe gerade das der von zapata verlinkte Thread offenbar genau meiner Beschreibung entspricht...

Foto
1

Ich habe den Hinweis vom Support schon verstanden, aber das hilft mir nicht weiter. Wenn in einer E-mail der String "Service-Team" (ist nur ein Beispiel) vorkommt und ich suche nach Team und die Nachricht wird gefunden und bei der Suche nach Service wird nichts angezeigt, dann liegt hier offenbar ein Bug (=Problem) vor! Aber bei OX wundert mich nichts mehr! :)

Foto
1

Hab ich auch bemerkt.Je kleiner der zu durchsuchende Ordner ist, desto präziser sind die Suchergebnisse. Bei großen Ordnern wird auch oft was nicht gefunden.

Foto
Foto
1

OK, mein IMAP client (Wanderlust) verhält sich wie die Websuche, wenn ich den Body durchsuche, also liegt es wohl nicht an OX. Mal gespannt, wann der Support mein Ticket abgearbeitet hat.


Und gerade wieder die Meldung:

Error

There was an issue while authenticating. This may be due to a recent password change. To continue please log out and log back in with your most current password.


Ich werde mir wohl mailcow oder dotplex näher anschauen müssen.

Foto
1

Hi Zapata, ch kann Deine vielen Fehler nicht nachvollziehen. Ich habe seit Wochen keine Probleme mehr gehabt. Besonders keine Anmeldeprobleme. Kannst Du ausschliessen das es an Deinem Systemsetup/Router/Firewall etc liegt??

Foto
1

Wenn die Zugangsdaten falsch sind/die Anmeldung fehlschlägt, erwarte ich mir, dass die Anmeldeseite erneut angezeigt wird und nicht, dass OX teilweise geladen wird (keine E-mails) und ich mich zuerst abmelden muss. Die erneute Anmeldung funktioniert dann meist.

Ich habe nur mit Mailbox.org Probleme, also würde ich sagen, dass mein System/Netzwerk OK ist.

Foto
1

Also das passiert so bei mir nicht... Bei mir steht dann folgendes: (und zwar immer).

  1. Login fehlgeschlagen Bitte versuchen Sie es erneut.

Foto
1

Diese Fehlermeldung hat nichts mit einer Anmeldung bei uns zu tun, sondern kann m.W.n. nur daher kommen, wenn *externe Drittaccounts* (RSS-Feeds, Xing, Twitter, fremde IMAP-Konten) nicht richtig eingebunden/geladen werden.


Das kann zuallererst also auch ein Problem dieses Drittanbieters sein -- und darum gibt es umgekehrt aber ja auch keinen Grund, warum wir den Nutzer auf unsere Plattform nicht arbeitsfähig reinlassen sollten.


Der Hinweis auf den Passwort-Change kommt daher, daß diese externen Zugangsdaten mit dem Userpasswort verschlüsselt werden und OX als Möglichkeit davon ausgeht, daß der User sein Passwort geändert hat und er darum für diese externen Drittaccounts kein valides Passwort mehr hat. Wenn der Nutzer das (externe) Passwort dann neu eingibt und es mit dem (neuen) mailbox-org-Passwort codiert wird, geht's ja dann wieder.

(Aus diesem Grund tun wir uns bei den Drittaccounts bei OneTimePasswörtern/Yubikey so schwer, denken aber, daß wir da eine Lösung haben.)

Foto
1

Eben schon wieder diese Fehlermeldung! Es sieht dann so aus:

87d969e6c243fd326c96fa62e827892b

Auf Drive, Kalender, Adressbuch, etc. habe ich Zugriff.

Und ich habe keine Dritt-Accounts angelegt.

Foto
1

Ok, interessant. Wenn Du keine Drittaccounts eingebunden hast, dann passt hier Peers (plausible) Erklärung nicht.

Foto
1

Scheinbar kommt die Meldung jetzt permanent.

Foto
1

Ich habe jetzt Rückmeldung zu meinem Suchproblem bekommen:

+---

Ich vermute Sie beziehen, sich auf den Forenbeitrag https://support.mailbox.org/topic/suche-in-e-mails

Ich kann Ihnen da grundsätzlich keine andere Antwort liefern als dort schon durch die Kollegen geschehen.

+----

Aha... eh alles super!

Foto
1

bei mir alles normal. komisch

Foto
1

Wenn ihr Nachrichten sucht, ladet am besten das Postfach runter und sucht lokal oder kopiert alles auf einen funktionierenden IMAP4 Server. Achja, was tut die Vapoware "Mailtrace"? Saftladen.

Foto
2

Wie gesagt, Deine Probleme kann ich nicht reproduzieren. Mailbox.org als Saftladen zu betiteln finde ich auch nicht gut. Peer hatte mal erläutert das wohl krankheitsbedingt Mailtrace zur Zeit hinterher hinkt. Ich selbst bin noch aktiver Beta Tester von Mailtrace - wenn ich es nutze klappt es auch gut.

Ich glaube viele Probleme sind bei OX direkt zu suchen und mailbox.org leistet hier ein wenig "Pionierarbeit" um Fehler auszumerzen. Was ansich eherenwert ist aber den Kunden nicht beeinträchtigen darf. Von OX und Mailbox würde ich mir mehr stability releases wünschen. Ich finde OX einerseits gut weil mächtiges und flexibles Tool aber auf der anderen Seite läuft es immer mal unrund. Wer für welchen Fehler verantwortlich ist kann ich nicht sagen. Irgendwie häng ich bei Mailbox fest weil deutscher mittelständischer Anbieter - was gefördert werden muss. Und ich finde die Heinlein Truppe irgendwie charmant. ;)

Alternativ habe ich noch einen Fastmail Account. Fastmail finde ich von Ansatz her auch ein sehr gutes Konzept und die sind auch schon seit Jahren am Markt. 100% IT'ler -wie Heinlein. Sie sind auch in wesentlichen Teilen für die Cyrus IMAP Server Weiterentwicklung verantwortlich. Daher sind sie bei Bugs direkt am Mann. Technisch finde ich viele innovative Features bei Fastmail die es bei Mailbox nicht gibt. Zum Beispiel CardDav & CalDav Push. Die Entwickeln ihre Platform aber auch komplett selbst. (und sind nicht auf OX angwiesen).Nur hat Fastmail die Server in USA stehen (NY) und Backup Server in Amsterdam. Fastmail sitzt jedoch in Melbourne / Australien.

So, das wars von mir... :)

Foto
1

Sorry, aber was soll die Antwort von Peer bzw. vom Support? Inwiefern hilft uns/mir das weiter? Vielleicht sollte zunächst mal der Tag "Kein Problem" wieder entfernt werden!?

Wann wurde Mailtrace mit "in Kürze" vorgestellt? Am 30.5.2016! Seit dem sind eh erst fast 19 Monate vergangen! Oder "Und so oder so steht in 2-3 Monaten unsere Mailapp für Android und iOS vor der Tür" Peer vor 5 Monaten.

Foto
1

Ende Oktober 2017 hat Peer mir zu Mailtrace geschrieben: "Aus Zeitgründen und da wir für uns wichtigere Projekte identifiziert haben, ruht das Projekt derzeit etwas. Wir werden es zu gegebener Zeit wieder aufnehmen."


Scheint also erstmal auf Halde zu liegen, oder kann man irgendwie als Betatester aufgenommen werden?

Foto
Foto
1

Bin gerade auf das Thema gestoßen, weil mich die Email-Suche im Webinterface seit Beginn auch stört. Ich nehme faktisch immer mein iPhone und suche nach Emails dort in der Mail-App, wechsle dann zu mailbox.org um dort dann eine sehr spezifische Suchanfrage machen zu können...das kann doch im Jahr 2019 nicht ernsthaft notwendig sein!


Auf der Hilfeseite für die Suche (https://office.mailbox.org/appsuite/help/l10n/de_DE/ox.appsuite.user.sect.email.search.html) heißt es: "Wenn Sie den Suchbegriff anklicken oder die Eingabetaste drücken, wird in den folgenden Daten gesucht: Absender, Empfänger, Betreff, E-Mail Text." Dann kann ich mir nicht erklären, warum bei einer Suche mit "Eingabetaste drücken" nur eine Mail gefunden wird, wenn ich aber manuell auf "im Email-Text" klicke, drei Mails auftauchen. Emails kann ich gerne bereitstellen, wenn dies der Problemfindung dient.


Sehr beunruhigend finde ich auch die Reaktionen von Peer Heinlein in bester "Servicewüste Deutschland"-Manier: bei Problemen erstmal auf andere (Drittanbieter oder User) zeigen, oder gar den ganzen Thread als "Kein Problem" taggen. Ich würde mir wünschen, dass die Anliegen der Nutzer ernster genommen werden. Alle, die hier geschrieben haben, haben offensichtlich ein Problem und sich die Zeit genommen, dieses zu formulieren. Man sollte dann zumindest versuchen, dem Nutzer weiterzuhelfen (etwa dadurch, weitere Informationen zu erfragen, wenn das Problem nicht reproduziert werden kann).

Foto
1

Kann man auch nur Teile eines Wortes suchen, bspw. statt Überweisungszweck nur nach Überweis*?

Foto
1

Kann ich leider auch nur bestätigen! Folgende Suche in allen Ordnern:

/78a18977cf0a8ccf65300b87c8101293

/dd16eed1f36a572c48e17edbb882102f/c0d3ab9e26758127aabda336f13b3f39

Foto
1

die Inbox-Verschlüsselung ist nicht aktiviert, oder? Dann müsste der Guard nämlich alles erst entschlüsseln, um es durchsuchen zu können und das macht er nicht automatisch

Foto
1

Bei PGP im Webmailer ist der Guard aktiviert (lässt sich ja auch nicht deaktivieren).

Bei z.B. dem String "Sparen" als Suchanfrage wird das Ergebnis korrekt angezeigt.

Foto