Willkommen im User-Forum von mailbox.org
 

Fehler "Domain not found", Kein Versand oder Empfang möglich

Karl hat dies geteilt, 12 Tage her
veröffentlicht

Hallo, ich habe gestern nur die Nameserver vom alten Anbieter auf Cloudflare geändert. Seitdem kann ich weder E-Mails an diese Domain schicken noch empfangen. Beim Senden erscheint immer die Fehlermeldung "Domain not found", obwohl die Domain in allen großen DNS Server korrekt synchronisiert ist.

Die MX DNS Einstellungen waren identisch mit dem vorherigen Einstellungen, die ich bereits beim alten Anbieter für mailbox.org hinterlegt hatte und erfolgreich getestet hatte. Nach Änderung der Nameserver ging bei mailbox.org nichts mehr (obwohl die Änderungen schnell verteilt waren und der neue Webserver sofort erreichbar war).

Ich habe den Umzug davor mit zwei anderen, nicht-kritischen Domains problemlos getestet und bin bei der neuen Domain genau gleich vorgegangen.

Ich habe heute um 8:30 ein Ticket eröffnet und noch keine Rückmeldung erhalten. Ich kann seit gestern 8 Uhr am Abend keine E-Mails mehr an diese Domain empfangen.

Bitte dringen um Antwort und Erklärung, wie das Problem behoben werden kann!

Antworten (2)

Foto
1

Dir ist bekannt, dass DNS-Änderungen bis zu 24 Stunden dauern können? Das kann für Webserver und Mailserver durchaus unterschiedlich sein.

Foto
1

Die DNS Einträge sind mit den vorherigen identisch. Nur der Nameserver hat sich geändert. Wenn ein Server noch die alten Werte hat oder sich schon die neuen Werte geholt hat, sind die Daten weiterhin gleich.

Ich habe den Umzug vorher mit denselben Anbietern zwei Mal mit anderen Domains durchgespielt und innerhalb weniger Stunden hat der E-Mail Empfang funktioniert.

Foto
1

mailbox.org bekommt von den geänderten DNS-Servern eigentlich gar nix mit.

> Ich habe den Umzug vorher mit denselben Anbietern zwei Mal mit anderen Domains durchgespielt und innerhalb weniger Stunden hat der E-Mail Empfang funktioniert.

Wenn es eine Downtime gibt, ist der Umzug nicht richtig gelaufen, würde ich sagen. Zuerst neue DNS-Records anlegen, schauen, dass die resolved werden, danach NS-Records umbiegen, warten bis die NS-Records aus dem Cache sind, danach kann man die alten DNS-Records rausnehmen. Das sollte Zero-Downtime liefern.

Foto
Foto
1

Zweite Domain umgezogen und wieder das exakt selbe Problem. Es sind jetzt mehr als 24 Stunden vergangen und ich habe noch immer keine einzige E-Mail empfangen.

Die DNS Einstellungen waren alle nach bereits nach einer halben Stunde nach Umstellung der Nameserver weltweit korrekt hinterlegt (https://dnschecker.org/). Auch https://mxtoolbox.com/ hat die korrekten Daten ausgegeben (die zuvor seit einer Woche beim alten Nameserver bereits hinterlegt waren).

Vom Support gibt es auch überhaupt keine Rückmeldung. Bitte dringend um Unterstützung, wie das Problem behoben werden kann.

Foto
1

Wie genau äußert sich das Problem? Fehlermeldung beim Senden einer Mail?

Kannst du mal genau beschreiben, was du wann in welcher Reihenfolge geändert hast?

Foto
1

Das Problem ist, dass keine E-Mails empfangen werden und beim Versenden erscheint die Fehlermeldung "Domain not found".

Das Vorgehen war wie folgt:

  • Beim alten Anbieter (DomainFactory) wurden die MX/TXT Einträge hinterlegt (letztes Wochenende). Nach ca. einer halben Stunde trafen auch schon die ersten E-Mails bei mailbox ein.
  • Bei Cloudflare wurden alle DNS Einträge 1:1 übernommen. Nur die Nameserver wurden am Freitag Abend bei DomainFactory auf Cloudflare geändert. Ansonsten gab es keine Änderung.
  • Sobald die neuen Nameserver hinterlegt waren wurden keine E-Mails mehr empfangen und es konnten keine mehr versendet werden.


Die DNS Einstellungen hatten sich nicht geändert, nur die Nameserver. Der Empfang/Versand über mailbox hat vor Änderung des Nameservers funktioniert, danach mit denselben DNS Einträgen nicht mehr.

Die DNS Einträge/die Nameserver von Cloudflare waren innerhalb einer halben Stunde weltweit korrekt hinterlegt (Google DNS, OpenDNS, Quad9, ...).

Foto
1

Verwendest du DNSSEC? Könnte das ein Problem sein? Ohne Angabe der Domain wird dir hier niemand weiterhelfen können. Wenn du sicher bist, dass alles passt, musst du wohl ein Ticket beim offiziellen Support von mailbox.org erstellen.

Foto
2

Das hier:

"Die DNS Einstellungen waren alle nach bereits nach einer halben Stunde nach Umstellung der Nameserver weltweit korrekt hinterlegt"

stimmt eben genau nicht und das ist auch das Problem.

DNS-Zonen haben eine sogenannte TTL. Diese wird vom Besitzer der Domain selbst (also Dir) eingestellt bzw. wenn man sie nicht separat einstellt, hat man eben den Default-Wert des Domainproviders, wo man die Domain eingekauft hat. Früher war die TTL eine Woche, heute nimmt man eher einen Tag. Weiß man, dassn man viele kurzfristige Änderungen braucht, setzen Profis die TTL rechtzeitig vor der Umstellung auf wenige Minuten herunter.

Andere DNS-Server dürfen nun bekannte DNS-Einträge eben genau diese TTL-Zeit puffern und cachen. Im Internet wird oft behauptet: "Verschiedene DNS-Server können bis zu einer Woche brauchen" - was gut gemeint, aber technisch falsch ist: Wenn ich die TTL auf 2 Stunden setze, dann *sind* es maximal 2 Stunden. Wenn ich es auf einen Tag oder eine Woche setze, dann eben maximal ein Tag oder eine Woche. Das ist wie gesagt weder willkürlich noch Zufall, sondern wird explizit als Wert in der DNS-Zone eingestell und wird vom Domainbesitzer (wissentlich oder unwissentlich) anderen Servern vorgegeben.

Wenn die TTL bei Deiner Domain eben einen Tag betrug, dann ist die Domain *nicht* nach einer halben Stunde weltweit korrekt hinterlegt. Es kann wird und darf (!) beliebig viele DNS-Server weltweit geben, die in den Minuten oder Stunden vor der Umstellung Daten der Domain abgefragt haben und diese Daten eben nun bis zur maximalen DNS-TTL-Zeit verwenden dürfen.

Wenn man Domain sunprofessionell mit langer TTL einfach so umstellt, wirst Du für die Dauer der TTL beliebig viele Negtaiv-Effekte haben (von Domain unbekannt bis hin zu Mails nach wie vor an alten Provider zugestellt). Es ist Zufallsprinzip, welcher Nameserver nun dann in dieser Zeit schon neue und wer noch alte Daten hat.

Wenn ich als Provider 3 DNS-Server intern betreibe, dann ist einer schon frisch, ein anderer hat noch 2 Stunden lang alte Daten und der Dritte vielleicht noch 21 Stunden. Alles Zufall.

Klar ist aber auch: Wenn man "einfach so" mal schnell umstellt, dann wird kann und MUSS es anfangs Kuddelmuddel geben und nicht gehen, wenn man die TTL eben nich vorher rechtzeitig auf 5 Minuten abgesenkt hat, um das zu minimieren.


All das hat mit mailbox.org und den von diesen Effekten betroffenen Providern absolut nix zu tun und ist auch keine Fehlfunktion, sondern Absicht und genau so, wie Internet und DNS by Design funtionieren soll.

Das zu erklären und Support zu geben, dem Nutzer ggf. Support und Helpdesk bei einer Umstellung zu geben, ist Aufgabe des DNS-Anbieters, der für diese Domain bezahlt wird.

Foto
1

Es ist sicher bekannt, dass nicht jeder Anbieter das Einstellen der TTL erlaubt. Bei DomainFactory sind die TTL nicht änderbar und sind laut FAQ 1 Stunde für Nameserver-Einträge:

"Die TTL (Time to Live) beträgt 60 Minuten, geänderte Nameserver-Einträge werden also innerhalb einer Stunde aktiv. Bei Änderung des MX-Records kann es bis zu 3 Stunden dauern, bis die Änderung aktiv wird."


Daher ist hier nur mit einer "maximalen DNS-TTL-Zeit" von einer Stunde zu rechnen und nicht mit einem Ausfall von mehr als 24 Stunden, besonders weil die MX Einträge beim alten Nameserver und beim neuen Nameserver 1:1 identisch sind. Diese Daten wurden auch schon seit fast einer Woche bei DomainFactory hinterlegt, um ggf. jegliche Verzögerungen zu berücksichtigen. Die Änderungen bei DomainFactory haben aber sofort gegriffen und der Mailempfang/-versand hat innerhalb einer Stunde mit mailbox.org funktioniert. Auch wenn auf einen alten, gecachten DNS Eintrag zugegriffen wird, wären diese Daten trotzdem 1:1 gleich gewesen. Ob ein DNS noch den Cache von DomainFactory hatte oder bereits die Daten von Cloudflare gezogen hatte, hätte daher zum selben Ergebnis geführt.


Wenn dann nur bei mailbox.org die Fehlermeldung "Domain not found" ist (von anderen E-Mail Anbietern konnte ich E-Mails an diese Domain schicken, ohne eine Fehlermeldung zu erhalten - empfangen wurden sie nicht), muss hier eine andere Einstellung dafür verantwortlich sein.


Übrigens hat sich der Support noch immer nicht gemeldet. Bei so einem kritischen Thema wie E-Mails, noch dazu bei einem Anbieter, der sich auf dieses Thema spezialisiert hat, hätte ich viel mehr vom Support erwartet, besonders in der heiklen Umstellungsphase.

Foto
1

Was ist denn die genaue Ticketnummer?

Foto
1

Hallo,

unser Support hat Ihr Ticket nun gefunden und wird sich umgehend darum kümmern.

Mit herzlichen Grüßen

Ihr mailbox.org Team

Foto
Hinterlassen Sie einen Kommentar
 
Dateianlage anfügen