Willkommen im User-Forum von mailbox.org
 

imap Verzeichnis-Struktur

6480510 hat dies geteilt, 2 Monaten her
unbeantwortet

Anscheinend wird nicht der komplette Verzeichnisbaum, wie im Account übers Web angezeigt, exportiert.

Ich war es bisher gewöhnt, einfach Verzeichnisse anzulegen und nach meinen Wünschen zu strukturieren, auch mit Unterverzeichnissen.

Bei mailbox.org bin ich nun auch so vorgegangen und wollte eine Struktur anlegen, aber - es werden anscheinend nur Ordner unter INBOX per imap exportiert. Warum?

Ich habe naiv auf dem phone den imap Zugriff eingerichtet, ging sofort, einige Ordner von da angelegt, diese wurden jedoch flach, ohne die Verzeichnisstruktur angezeigt.

Also im Web OX angemeldet, dort werden diese Ordner separat unter mailbox.org, als separater Baum neben INBOX, Trash... angezeigt.

Auch gut, dachte ich und lege halt im Web grob eine Struktur unter mailbox.org an, wenn das so vorgesehen ist (ich habe diesen Ordner nicht angelegt, der kam implizit automatisch). Jedoch werden diese, unterhalb mailbox.org, nun ebenfalls nicht über imap sichtbar, die vom phone angelegten schon, aber flach, ohne die Verzeichnisstruktur.

Grübel, bisher ging das mit allen imap die ich verwendet habe. Bei posteo werden alle Ordner so angezeigt wie ich sie anlege, identisch mit der Webansicht. Egal ob ich dort Nachrichten per Filter hinsortieren lasse oder manuelle Ablagen.

Bitte um Hilfe und Erklärung ;-)

Kommentare (7)

Foto
1

Das kann ich so nicht ganz bestätigen. Bei mir sind alle Ordner aus der mailbox.org-Webansicht auch in meinen Clients per IMAP vorhanden. Dazu gehören die Systemordner (Posteingang, Papierkorb usw.) und die selbst angelegten Ordner mit Unterordnern, die in der Webansicht nach den Systemordnern und der Zwischenüberschrift 'mailbox.org' angezeigt werden. (Und darunter kommen die mir freigegebenen Ordner aus anderen Team-Accounts. Auch die werden in meinen Clients unter 'shared' angezeigt.) Als bis dahin analog zur obigen Schilderung.

Wenn ich aber in der OX-Oberfläche Unterordner anlege, dann werden die z.B. in Thunderbird (Postbox) unter Windows oder auf meinem iPhone auch als Unterordner (eingerückt) angezeigt.

Foto
1

Die Frage ist glaube ich, legt man Unterordner unter INBOX an, oder macht man so Ordner parallel zur INBOX?

Foto
1

Beides.

Bei mailbox.org scheint die Variante unter INBOX bevorzugt zu werden, wie ich aus meinen Rechergen hier zum Thema schließe.

Es macht aber durchaus Sinn beides zu haben, Ordner unter INBOX und separat.

Unter INBOX filtere ich einen alias bspw. als separate Posteingänge direkt in eigene Ordner.

Sortiertes oder shops, unwichtiges, über normale Filter geht in die übrigen Ordner.

Das hat folgenden Grund:

Man kann oft beim abbonieren von Ordnern INBOX nicht abwählen und direkt ein Unterverzeichnis, so zumindest bei meinen phones. Somit würde ich immer bei jeder Mail benachrichtigt, die eingeht, wenn alles irgendwie unter INBOX liegt. Das will ich definitiv nicht! Jedoch der Posteingang der Adressen oder Alias schon. Die übrigen und das ist mengenmäßig das Meiste, geht dann per Filter oder beim durchsehen manuell in die Ordner außerhalb INBOX.

Somit werde ich benachrichtigt über neue Mails, was nicht bereits per Filter weggefiltert wird und den Rest schaue ich mir an, wenn ich ins Postfach schaue.

Bei posteo habe ich die IMAP Baumstruktur genauso wie im Postfach angelegt, zum aufklappen der Unterordnerstruktur und ich kann die Ordner, bei denen ich benachrichtigt werden möchte, "abbonieren", den Rest sehe ich wenn ich das Postfach öffne.


Nachtrag:

Auch wenn die Struktur unter INBOX nett ist, ich könnte am ehesten auf diese Variante verzichten, hätte lieber Ordner neben INBOX für meine Mailorganisation, falls es gemischt nicht gehen sollte. Der Grund steht oben.

Foto
Foto
1

Ok, danke für den Hinweis, es müsste also so gehen, wie ich es erwarte - dann suche ich mal weiter...

Foto
1

Wenn ich in Outlook 2019 bei den IMAP Einstellung, unter Stammordnerpfad INBOX eingebe, fehlen mir die angelegten Ordner. Lösche die die INBOX Buchstaben, sind alle selbst angelegten Ordner auch in Outlook vorhanden. Mit einem Test Account nahm es nicht alle Ordner mit. Bei Zahlung von 2 Euro für 2 Monate, klappte es mit den Ordnern.

Foto
1

Durch umbenennen der extern per IMAP (vom phone) angelegten Ordner reparierte sich das Ganze bei mir.

Alle weiteren erstellten Ordner und Unterordner, sowohl unter INBOX als auch die separaten unter mailbox.org werden danach korrekt angezeigt und alles funktioniert nun - wenn sie in der OX Oberfläche von mailbox.org angelegt werden, das habe ich mit den übrigen getan, geht auch schneller als am phone.

Ich denke die Sache kam durcheinander beim anlegen des allerersten Ordners auf oberster Ebene, beside INBOX, wo die nicht zu ändernde Überschrift "mailbox.org" erstmalig auftauchte unter der dieser Ordner und alle übrigen, die nicht unter INBOX liegen, angelegt werden. Das erfolgte in meinem Fall vom phone aus per IMAP. Der erste Ordner wurde nach Erstellung nicht richtig angezeigt, dann ohne jegliche Beschriftung nach Aktualisierung, der Zweite gar nicht mehr, fehlte nach "aktualisieren", aber in der OX Oberfläche waren sie da. Vermutlich kam der IMAP client seitig durch die unerwartete Strukturerweitung "mailbox.org" auf Serverseite durcheinander.

Die extern vom phone per IMAP unter INBOX angelegten Ordner haben allerdings problemlos funktioniert, nur ist hier die Steuerung der Benachrichtigung bei neu eingegangenen mails für die Unterverzeichnisse nicht wirklich gut möglich, da INBOX selbst i.R. nicht abwählbar ist und somit immer der komplette Baum für Neueingänge überprüft wird.

Umbenennen und zurück umbenennen bzw. von der OX Web Oberfläche aus anlegen hat bei mir die Lösung gebracht.

Foto
1

>"Stammordnerpfad INBOX"

Ich kann zu Outlook selbst nichts sagen, benutze ich nicht, aber falls damit so etwas wie:

"Präfix für den IMAP Pfad"

gemeint ist, was eine Art Einstiegspunkt im IMAP Pfad darstellt, ab dem die Ordnerstruktur gelesen werden soll, dann lass das am besten leer. Mit der Struktur hier funktioniert das nicht bzw. wird nicht benötigt und löst auch das geschilderte Problem nicht.